hdu 1829 A Bug's Life (判断二分图)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1829

A Bug's Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12112    Accepted Submission(s): 3952


Problem Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:  1558 1811 2473 3172 3234 

题目大意:给出一些关系,判断是否存在同性恋,简单的说就是判断是否是二分图。

这里新学了一种建图的方法,离散化建图。
解题思路:二分图的判断+bfs,如果不用离散化建图会数组越界RE。

详见代码。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

int judge[2010];
int n,m;
int num,head[2010];

struct edge
{
    int st,ed,next;
} e[2010*1000];

void addedge(int x,int y)
{
    e[num].st=x;
    e[num].ed=y;
    e[num].next=head[x];
    head[x]=num++;
    e[num].st=y;
    e[num].ed=x;
    e[num].next=head[y];
    head[y]=num++;
}

bool bfs(int x)
{
    queue<int>q;
    q.push(x);
    judge[x]=0;
    //cout<<x<<endl;
    while (!q.empty())
    {
        int s=q.front();
        q.pop();
        for(int i=head[s]; i!=-1; i=e[i].next)
        {
            //cout<<judge[i]
            if (judge[e[i].ed]==-1)
            {
                judge[e[i].ed]=(judge[s]+1)%2;
                q.push(e[i].ed);
            }
            else
            {
                if (judge[e[i].ed]==judge[s])
                    return false;
            }
        }
    }
    return true;
}

int main()
{
    int flag;
    int tt=1;
    int t;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d%d",&n,&m);
        flag=1;
        //memset(Map,0,sizeof(Map));
        memset(judge,-1,sizeof(judge));
        int a,b;
        num=0;
        memset(head,-1,sizeof(head));
        for (int i=1; i<=m; i++)
        {
            scanf("%d%d",&a,&b);
            addedge(a,b);
        }
        for (int i=1; i<=n; i++)
        {
            if(judge[i]==-1)
            {
                if (!bfs(i))
                    flag=0;
            }
        }
        printf ("Scenario #%d:\n",tt++);
        if (flag==1)
            printf ("No suspicious bugs found!\n");
        else
            printf ("Suspicious bugs found!\n");
        printf ("\n");
    }
    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值