E - Easy Task --- (fisrt qualifying)

E - Easy Task
时限:2000MS     内存:65536KB     64位IO格式:%lld & %llu

问题描述

Calculating the derivation of a polynomial is an easy task. Given a function f(x) , we use (f(x))' to denote its derivation. We use x^n to denote xn. To calculate the derivation of a polynomial, you should know 3 rules: 
(1) (C)'=0 where C is a constant. 
(2) (Cx^n)'=C*n*x^(n-1) where n>=1 and C is a constant. 
(3) (f1(x)+f2(x))'=(f1(x))'+(f2(x))'. 
It is easy to prove that the derivation a polynomial is also a polynomial.

Here comes the problem, given a polynomial f(x) with non-negative coefficients, can you write a program to calculate the derivation of it?


输入

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 1000) which is the number of test cases. And it will be followed by T consecutive test cases.

There are exactly 2 lines in each test case. The first line of each test case is a single line containing an integer N (0 <= N <= 100). The second line contains N + 1 non-negative integers, CNCN-1, ..., C1C0, ( 0 <= Ci <= 1000), which are the coefficients of f(x). Ci is the coefficient of the term with degree i in f(x). (CN!=0)


输出

For each test case calculate the result polynomial g(x) also in a single line. 
(1) If g(x) = 0 just output integer 0.otherwise 
(2) suppose g(x)= Cmx^m+Cm-1x^(m-1)+...+C0 (Cm!=0),then output the integers Cm,Cm-1,...C0.
(3) There is a single space between two integers but no spaces after the last integer. 


样例输入

3
0
10
2
3 2 1
3
10 0 1 2


样例输出

0
6 2
30 0 1


分析:水题。一开始读题没明白题意,来回看了几遍,尝试了一下例子,写了代码提交就AC了。

大体题意:输入一个N值,代表第一个x的指数,然后指数是下降的,直到最后一个是常数,所以最后一个数并没有什么卵用。然后对函数进行求一次导,输出每一个系数的值。因此,用输入第i的数乘以N-i+1得到值就是答案。


CODE:

<span style="font-size:18px;">#include <iostream>
using namespace std;

int main()
{
    int t;
    cin>>t;
    while(t--){
        int n,tmp,a;
        cin>>n;
        tmp=n;
        int ans[105];
        for(int i=0;i<=n;i++){
            cin>>a;
            ans[i]=a*tmp;
            tmp--;
        }
        cout<<ans[0];
        for(int i=1;i<n;i++)
            cout<<' '<<ans[i];
        cout<<endl;
    }
    return 0;
}</span>



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值