J - Intelligent IME---(2015 summer training #3)

J - Intelligent IME
时限:1000MS     内存:32768KB     64位IO格式:%I64d & %I64u

问题描述

  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below: 
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o     
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z 
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences? 
 

输入

  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this: 
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words. 
 

输出

  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line. 
 

样例输入

     
     
1 3 5 46 64448 74 go in night might gn
 

样例输出

     
     
3 2 0

分析:手机键盘,给你一个数,然后给你很多字符串,问你用这个数敲打键盘,能打出多少给定的字符串?

思路:根据每个给出的字符串,写出相应的数字,然后和输入的比较是否相等。(哈希算法)


CODE:

#include <iostream>
#include <string.h>
using namespace std;

int ans[1000005];

int main()
{
    int key[127];
    key['a']=key['b']=key['c']=2;
    key['d']=key['e']=key['f']=3;
    key['g']=key['h']=key['i']=4;
    key['j']=key['k']=key['l']=5;
    key['m']=key['n']=key['o']=6;
    key['p']=key['q']=key['r']=key['s']=7;
    key['t']=key['u']=key['v']=8;
    key['w']=key['x']=key['y']=key['z']=9;
    int t;
    cin>>t;
    while(t--){
        int n,m,a[5005];
        memset(ans,0,sizeof(ans));
        char b[5005][8];
        cin>>n>>m;
        for(int i=0;i<n;i++) cin>>a[i];
        for(int i=0;i<m;i++){
            cin>>b[i];
            int sum=0;
            for(int j=0;j<strlen(b[i]);j++)
                    sum=sum*10+key[(int)b[i][j]];
            ans[sum]++;
        }
        for(int i=0;i<n;i++)
            cout<<ans[a[i]]<<endl;
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值