HDU 4287 Intelligent IME

5 篇文章 0 订阅

Problem Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c 3 : d, e, f 4 : g, h, i 5 : j, k, l 6 : m, n, o
  7 : p, q, r, s 8 : t, u, v 9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.

Sample Input
1
3 5
46
64448
74
go
in
night
might
gn

Sample Output
3
2
0

题意:
已知数字与字母的对应关系,第一行输入测试次数T,接着输入数字串的个数N与字典中单词的个数M,然后分别输入N个数字串和M个单词,对于每个数字串,输出字典中能打出的单词的个数
思路:
定义一个map < string,int > 来存储每个数字串对应的单词个数,循环字典中每一个单词,将其转化为数字串

AC代码

//
//  main.cpp
//  hdu 4287 Intelligent IME
//
//  Created by nuu_tong on 2017/9/16.
//  Copyright © 2017年 apple. All rights reserved.
//

#include <iostream>
#include<string>
#include <map>
using namespace std;
string sequences[5001];
string words[5001];
map<string,int> button;
map<string,int>::iterator it;
string str="22233344455566677778889999";//用string储存26个字母对应的数字
void findWords(int N,int M)
{
    int i,k;
    string s;
    for(i=0;i<M;i++)//循环字典中每一个单词
    {
        s=words[i];
        for(k=0;k<s.length();k++)
        {
            s[k]=str[s[k]-'a'];//将单词转化为相应的数字串
        }
        button[s]++;//将该数字串储存到map中
    }
    for(i=0;i<N;i++)
    {
        s=sequences[i];
        printf("%d\n",button[s]);//输出每个数字串对应的个数
    }
}
int main()
{

    int i,T,N,M;
    char ch[7];
    string s;
    cin>>T;
    while(T>0)
    {
        button.clear();
        cin>>N>>M;
        for(i=0;i<N;i++)
        {
            scanf("%s",ch);//用scanf读取,提高运行速度
            s=ch;
            sequences[i]=s;//将数字串加入到line数组中
        }
        for(i=0;i<M;i++)
        {
            scanf("%s",ch);
            s=ch;
            words[i]=s;
        }
        findWords(N,M);
        T--;
    }
       return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值