HDU1010 Tempter of the Bone DFS

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 99555    Accepted Submission(s): 26979


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
 
题意:给定一个迷宫,X为不可路过点,S为起始点,D为重点,“.”为一般点,每移动一次需要1秒,经过的点不能再经过,问能否恰好在t秒的时候到出口。
解:深搜即可。
代码:
//************************************************************************//
//*Author : Handsome How                                                 *//
//************************************************************************//
//#pragma comment(linker, "/STA    CK:1024000000,1024000000")
#pragma warning(disable:4996) 
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <complex>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <ctime>                                                
#include <cassert>
using namespace std;
typedef long long LL;
char maze[10][10];
int vis[9][9];
int m, n, t;
int dx[] = { -1,0,1,0 };
int dy[] = { 0,-1,0,1 };
int doorx, doory;
bool check(int x, int y) { return (x >= 0 && x < m&&y >= 0 && y < n); }
bool dfs(int x, int y,int now)
{
    if (x == doorx&&y == doory&&now == t)  return true; 
    for (int i = 0; i < 4; i++)
    {
            if (check(x + dx[i], y + dy[i]))
                if(vis[x + dx[i]][y + dy[i]]==0)
                {
                    vis[x + dx[i]][y + dy[i]] = 1;
                    if (dfs(x + dx[i], y + dy[i], now + 1)) return true; 
                    vis[x + dx[i]][y + dy[i]] = 0;
                }
    }
    return false;
}

int main()
{
    while (scanf("%d%d%d", &m,&n,&t) != EOF)
    {
        if (m == 0 && n == 0 && t == 0)break;
        getchar();
        memset(vis, 0, sizeof(vis));
        doorx = -1;
        int sx = -1, sy = -1;
        for (int i = 0; i < m; i++)
        {
            scanf("%s", maze[i]); getchar();
        }
        if (t >= m*n) { printf("NO\n"); continue; }
        for (int i = 0; i < m; i++)
            for (int j = 0; j < n; j++)
            {
                if (maze[i][j] == 'S') { sx = i, sy = j; vis[sx][sy] = 1;}
                if (maze[i][j] == 'D') { doorx = i, doory = j; }
                if (maze[i][j] == 'X') { vis[i][j] = 1; }
            }
        if ((abs(sx - doorx) + abs(sy - doory) - t) & 1) printf("NO\n");
        else if (dfs(sx, sy,0))printf("YES\n");
        else printf("NO\n");    
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值