HDU-1241 Oil Deposits(简单DFS)

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
InputThe input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
OutputFor each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
Sample Output
0
1
2
2


题目大概意思是有一个n行m列的网格,其中*代表没油,@代表有油(如果两个格子相邻则视为同一个油田),问共有多少油田

简单DFS

AC代码

#include<stdio.h>

char inf[150][150];
int n,m;

void dfs(int x,int y){
    //将现在所在位置替换成*
    inf[x][y] = '*';
    //循环遍历移动的8个方向
    for(int dx = -1;dx <= 1;dx++){
        for(int dy = -1;dy <= 1;dy++){
            //向x方向移动dx,向y方向移动dy,移动结果为(nx,ny)
            int nx = x + dx,ny = y + dy;
            if(nx >= 0 && nx < n && ny >= 0 && ny < m && inf[nx][ny] == '@')
                dfs(nx,ny);
        }
    }
    return ;
}

int main(){
    while(scanf("%d %d",&n,&m)!=EOF && n != 0 && m != 0){
        int ans = 0;
        getchar();
        for(int i = 0;i < n;i++){
                scanf("%s",inf[i]);
            getchar();
        }

        for(int i = 0;i < n;i++){
            for(int j = 0;j < m;j++){
                if(inf[i][j] == '@'){
                    ans++;
                    dfs(i,j);
                }
            }
        }

        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值