Rightmost Digit 快速幂取模

 Rightmost Digit
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a positive integer N, you should output the most right digit of N^N. 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 

Output

For each test case, you should output the rightmost digit of N^N. 

Sample Input

2
3
4

Sample Output

7
6


        
  

Hint

     
     
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
这个题目有两个地方需要优化,一是利用快速幂进行求幂运算,二是因为题目让求的只是结果的最后一位数,所以其实每次只进行数的最后一位数的运算就行,因为两个数想乘影响最后最后一位数的只有这两个数的最后一位数
AC代码:
#include<iostream>      
#include<cstdio>      
#include<cstdlib>      
#include<cstring>      
#include<string>      
#include<queue>      
#include<algorithm>      
#include<map>      
#include<iomanip>       
#define INF 99999999      
#define maxn 100005     
using namespace std;  

void solve(int a, int b, int c) {
	int temp = a%10, ans = 1;
	while(b) {
		if(b&1)
			ans = ans*temp%c;
		temp = temp*temp%c;
		b = b>>1;
	}
	printf("%d\n",ans);
}    

int main()
{
	int t, n;
	scanf("%d",&t);
	while(t--) {
		scanf("%d",&n);
		solve(n, n, 10);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值