Fibonacci Check-up 矩阵快速幂

Fibonacci Check-up
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Every ALPC has his own alpc-number just like alpc12, alpc55, alpc62 etc. 
As more and more fresh man join us. How to number them? And how to avoid their alpc-number conflicted? 
Of course, we can number them one by one, but that’s too bored! So ALPCs use another method called Fibonacci Check-up in spite of collision. 

First you should multiply all digit of your studying number to get a number n (maybe huge). 
Then use Fibonacci Check-up! 
Fibonacci sequence is well-known to everyone. People define Fibonacci sequence as follows: F(0) = 0, F(1) = 1. F(n) = F(n-1) + F(n-2), n>=2. It’s easy for us to calculate F(n) mod m. 
But in this method we make the problem has more challenge. We calculate the formula  , is the combination number. The answer mod m (the total number of alpc team members) is just your alpc-number.

Input

First line is the testcase T. 
Following T lines, each line is two integers n, m ( 0<= n <= 10^9, 1 <= m <= 30000 )

Output

Output the alpc-number.

Sample Input

2
1 30000
2 30000

Sample Output

1
3
 
    
hdu2855
 
    
 
    
 
    

解题思路:这题我也不会推,打表可以得到结论。。。 
G(n) = 3 * G(n-1) - G(n-2),G函数表示这里写图片描述 
这题要注意最后求得的可能是负数,所以最后要处理一下

AC代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 31
int n, k, mod;
struct Matrix {
	int ma[3][3];
};

Matrix multi(Matrix a, Matrix b) {
	Matrix ans;
	memset(ans.ma, 0, sizeof(ans.ma));
	int i, j, k;
	for(i=1; i<=n; ++i)
		for(j=1; j<=n; ++j)
			for(k=1; k<=n; ++k)
				ans.ma[i][j] = (ans.ma[i][j] + a.ma[i][k]*b.ma[k][j]%mod) % mod;
    return ans;
}

Matrix pow(Matrix a, int x) {
	Matrix ans;
	memset(ans.ma, 0, sizeof(ans.ma));
	int i, j;
	for(i=1; i<=n; ++i)
		ans.ma[i][i] = 1;
	while(x) {
		if(x & 1)
			ans = multi(ans, a);
		a = multi(a, a);                         
		x >>= 1;
	}
	return ans;
}

int main()
{
	int t;
	Matrix ans, a;
	scanf("%d", &t);
	while(t--) {
		scanf("%d%d",&k,&mod);
		if(k==0) {
			printf("%d\n",k)%mod;
			continue;
		}
		n = 2;
		ans.ma[1][1] = 3;
		ans.ma[1][2] = 1;
		ans.ma[2][1] = -1;
		ans.ma[2][2] = 0;
		ans = pow(ans, k-1);
		memset(a.ma, 0, sizeof(a.ma));
		a.ma[1][1] = 1;
		ans = multi(a, ans);
		printf("%d\n",(ans.ma[1][1] + mod)%mod); //结果可能为负数,要处理一下
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值