Problem Description
The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)
…
an, a1, a2, …, an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output
16
思路
这道题的数据。。。
我好像暴力就可以啊。。。
代码
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
const int N=5000+5;
int a[N],n,ans=999999999;
int main()
{
while(scanf("%d",&n)!=EOF)
{
int num=0;
ans=999999999;
for (int i=0;i<n;i++)
scanf("%d",&a[i]);
for (int i=0;i<n;i++)
for (int j=i+1;j<n;j++)
if (a[i]>a[j]) num++;
if (ans>num) ans=num;
for (int i=0;i<n;i++)
{
num=num-a[i]+n-1-a[i];
if (ans>num) ans=num;
}
printf("%d\n",ans);
}
return 0;
}
天啦太神奇了