hdu 2460 Network Tarjan缩点+LCA 解题报告

Problem Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can’t be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0

题意:

给出一个无向图以及Q次询问,每次询问增加一条无向边,要求输出增加这条边后剩余的桥的数目。

思路:

先Tarjan割点,做一次dfs求出所有的桥,当一次询问加入一条边(a,b)之后,会在树上形成一个环,在这个环上的桥都变为非桥,并且这个环肯定经过a和b的LCA,此时我们只需在求LCA的过程中把经过的为桥的树边标记为非桥,同时cnt_bridge再输出即可。

需要注意的是树边的编号是用树边指向的那个节点的编号来表示的,例如树边

代码

最近老是刷这种不清真的题目。我开始怀念板子裸题1A的时候了。。。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<vector>
#include<stack>
using namespace std;
const int N=100000+10;
int low[N],dfn[N],iscut[N],tim=0;
bool isbridge[N];
vector<int> G[N];
int cnt_bridge,Q,father[N];
int dfs(int u, int fa)
{
    father[u]=fa;
    int lowu=dfn[u]=++tim,child=0;
    for (int i=0;i<G[u].size();i++)
    {
        int v=G[u][i];
        if (!dfn[v]) 
        {
            child++;
            int lowv=dfs(v,u);
            lowu=min(lowu,lowv); 
            if (lowv>dfn[u])
            {
                isbridge[v]=1;
                cnt_bridge++;
            }
        }
        else if (dfn[v]<dfn[u]&&v!=fa) lowu=min(lowu,dfn[v]);
    }
    if (fa<0&&child==1) iscut[u]=0;
    return low[u]=lowu;
}
void LCA(int a,int b)
{
    while(dfn[a]>dfn[b])
    {
        if (isbridge[a]) {isbridge[a]=0;cnt_bridge--;}
        a=father[a];
    }
    while(dfn[b]>dfn[a])
    {
        if (isbridge[b]) {isbridge[b]=0;cnt_bridge--;}
        b=father[b];
    }
    if (a!=b)
    {
        while(dfn[a]>dfn[b])
        {
            if (isbridge[a]) {isbridge[a]=0;cnt_bridge--;}
            a=father[a];
        }
        while(dfn[b]>dfn[a])
        {
            if (isbridge[b]) {isbridge[b]=0;cnt_bridge--;}
            b=father[b];
        }
    }
}
int main()
{
    int n,m,Case=1;
    while(scanf("%d %d",&n,&m))
    {
        if (n==0&&m==0) break;
        memset(isbridge,0,sizeof(isbridge));
        memset(dfn,0,sizeof(dfn));
        cnt_bridge=tim=0;
        for (int i=0;i<n;i++)
        G[i].clear();
        for (int i=0;i<m;i++)
        {
            int a,b;
            scanf("%d %d",&a,&b);
            a--;b--;
            G[a].push_back(b);
            G[b].push_back(a);
        }
        dfs(0,-1);
        scanf("%d",&Q);  
        printf("Case %d:\n",Case++);
        while(Q--)
        {
            int a,b;
            scanf("%d %d",&a,&b);
            a--;b--;
            LCA(a,b);
            printf("%d\n",cnt_bridge);
            if (Q==0) printf("\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值