PAT A1100 Mars Numbers(20)[火星数字,进制]

People on Mars count their numbers with base 13:

  • Zero on Earth is called “tret” on Mars.
  • The numbers 1 to 12 on Earth is called “jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec” on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as “tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou”, respectively.

For examples, the number 29 on Earth is called “hel mar” on Mars; and “elo nov” on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

题意

思路1

  1. 预处理出所有地球数字与火星数字对应的映射关系( 169*2)
  2. 根据查询输出即可

代码1

#include <iostream>
#include <string>
#include <unordered_map>
#include <algorithm>
using namespace std;
const int maxn = 200;
string lower[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string upper[13] = {"tret", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
string num2Str[maxn];               // 数字转字符串
unordered_map<string, int> str2Num; // 字符串转数字

// 打表初始化
void init()
{
    // 只有一个数情况
    for (int i = 0; i < 13; i++)
    {
        num2Str[i] = lower[i];      // 十位为0
        num2Str[i * 13] = upper[i]; // 个位为0
        str2Num[lower[i]] = i;
        str2Num[upper[i]] = i * 13;
    }

    // 有两个数情况
    for (int i = 1; i < 13; i++)
    {
        for (int j = 1; j < 13; j++)
        {
            string str = upper[i] + " " + lower[j];
            num2Str[i * 13 + j] = str;
            str2Num[str] = i * 13 + j;
        }
    }
}

int main()
{
    init();
    int N;
    scanf("%d", &N);
    getchar();
    while (N--)
    {
        string str;
        getline(cin, str);
        if (str[0] >= '0' && str[0] <= '9') // 数字
        {
            int res = 0;
            for (int i = 0; i < str.size(); i++)
            {
                res = res * 10 + str[i] - '0';
            }
            cout << num2Str[res] << endl;
        }
        else // 火星文
        {
            cout << str2Num[str] << endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值