PAT A1100 Mars Numbers (20分)

People on Mars count their numbers with base 13:
Zero on Earth is called “tret” on Mars.
The numbers 1 to 12 on Earth is called “jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec” on Mars, respectively.
For the next higher digit, Mars people name the 12 numbers as “tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou”, respectively.
For examples, the number 29 on Earth is called “hel mar” on Mars; and “elo nov” on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

题意:

输入地球数字或火星数字,输出对应的火星数字和地球数字.

思路:

(1)因为涉及的地球数字范围为[0,169),所以将地球数字到火星数字的映射和火星数字到地球数字的映射都实现,即打表;
(2)打表要注意在[0,169)内,只有当地球数字为13的倍数或属于[0,13)时,对应的火星数字为一个单位,否则为两个单位.

代码:

#include <cstdio>
#include <iostream> 
#include <string>
#include <map>
using namespace std;

string numToStr[170];
map<string,int> strToNum;
string lowDigit[15] = {"tret","jan","feb","mar","apr","may","jun",
					"jly","aug","sep","oct","nov","dec"};
string highDigit[15] = {"tret","tam","hel","maa","huh","tou","kes",
					"hei","elo","syy","lok","mer","jou"};
void init(){//对numToStr[170]、strToNum初始化 
	for(int i=0;i<13;i++){//初始化火星数字长度为一的数 
		numToStr[i] = lowDigit[i];//0-12
		strToNum[lowDigit[i]] = i;
		numToStr[i*13] = highDigit[i];//13的倍数 
		strToNum[highDigit[i]] = i*13;
	}
	for(int i=1;i<13;i++){//初始化火星数字长度为二的数
		for(int j=1;j<13;j++){
			string str = highDigit[i]+" "+lowDigit[j];
			numToStr[i*13+j] = str;//0-12
			strToNum[str] = i*13+j;
		} 
	}
}

int main(){
	init();//打表 
	int n;
	scanf("%d",&n);
	getchar();
	string str;
	while(n--){
		getline(cin,str);//获取一行 
		if(str[0]>='0'&&str[0]<='9'){
			int temp = 0;
			for(int i=0;i<str.length();i++){
				temp = temp*10+(str[i]-'0');
			}
			cout<<numToStr[temp]<<endl; 
		}else{
			cout<<strToNum[str]<<endl;
		}
	}
	return 0;
}


词汇:

mutual 相互的

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值