HDU 6159 cable cable cable (规律水题)

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=6195

Connecting the display screen and signal sources which produce different color signals by cables, then the display screen can show the color of the signal source.Notice that every signal source can only send signals to one display screen each time. 
Now you have MM display screens and KK different signal sources(K≤M≤232−1K≤M≤232−1). Select KK display screens from MM display screens, how many cables are needed at least so that **any** KK display screens you select can show exactly KK different colors. 

Input

Multiple cases (no more than 100100), for each test case: 
there is one line contains two integers MM and KK. 

Output

Output the minimum number of cables NN. 

Sample Input

3 2
20 15

Sample Output

4
90

        
  

题意:

每个信号源都有不同的颜色,有M个显示屏和K个信号源,求最少的连线使得k个显示屏有k种颜色 

思路:

先取k个显示屏各连一个信号源。剩下的(m-k)个显示屏必然每个都连k个信号源才能满足条件。

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int main()
{
    ll n,k;
    while(~scanf("%lld%lld",&n,&k)){
        printf("%lld\n",(n-k+1)*k);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值