Cable master

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input
The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
Output
Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39
Sample Output

2.00


思路:比赛的时候看这道题,因为英语水平着实不高,一脸懵逼。今天用了翻译,摸清题意后,才发现其实用一个简单二分就能过。题意是有n段绳子,要被分成k段大小一样的绳子,并且k要尽可能大。但是我发现数据也不小,所以,完全可以用二分不断去固定范围内去寻找,昨天就做了一道用二分解方程,有所感悟(其实就是在一定范围内寻找答案。。。)

代码:


#include<cstdio>
#include<cstring>
#include<cmath>
#define maxn 10010
double a[maxn];
int n,k;
bool check(double x)//判断当前这个值是否满足
{
    int num=0;
    for(int i=0; i<n; ++i)
        num+=(int)(a[i]/x);
    return num>=k;//个数一定要大于等于k
}
int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        double sum=0;
        for(int i=0; i<n; ++i)
        {
            scanf("%lf",&a[i]);
            sum+=a[i];
        }
        sum/=k;//很好的把二分范围缩小了,最多只能是平均
        double l=0,r=sum,mid;
        while(r-l>1e-5)
        {
            mid=(l+r)/2;
            if(check(mid))
                l=mid;
            else
                r=mid;
        }
    printf("%0.2f\n",floor(r*100)/100);//此处不能直接用%.2lf,因为它会自动向上取证,而题意需要的是向下取整。
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值