POJ 3279 Fliptile

Fliptile

https://vjudge.net/problem/POJ-3279
Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input

Line 1: Two space-separated integers: M and N
Lines 2… M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1… M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

C++

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int n, m;
int maze[20][20], tmp[20][20], cnt[20][20], ans[20][20];
int dir[5][2] = {0,1,1,0,0,0,0,-1,-1,0};
const int INF = 0x3f3f3f3f;
int minn = INF;
bool flag = false;

void flip(int a[][20], int x, int y)
{
	for(int i = 0; i < 5; i ++){
		int tx = x + dir[i][0];
		int ty = y + dir[i][1];
		if(tx >= 0 && tx < n && ty >= 0 && ty < m)
		{
			a[tx][ty] = 1 - a[tx][ty];
		}		
	}
}

int check()
{
	int t = 0;
	for(int i = 1; i < n; i ++){
		for(int j = 0; j < m; j ++){
			if(tmp[i - 1][j]){
				flip(tmp, i, j);
				cnt[i][j] = 1;
			}
			else cnt[i][j] = 0;
		}
	}
	for(int i = 0; i < m; i ++){
		if(tmp[n - 1][i]) return INF;
	}
	for(int i = 0; i < n; i ++){
		for(int j = 0; j < m; j ++){
			if(cnt[i][j]) t ++;
		}
	}
	return t;
}

void dfs(int col){
	if(col == m){
		for(int i = 0; i < n; i ++)
			for(int j = 0; j < m; j ++)
				tmp[i][j] = maze[i][j];
		int t = check();
		if(t < minn){
			minn = t;
			flag = true;
			for(int i = 0; i < n; i ++)
				for(int j = 0; j < m; j ++)
					ans[i][j] = cnt[i][j];
		}
		return;
	}
	dfs(col + 1);	
	flip(maze, 0, col);
	cnt[0][col] = 1;
	dfs(col + 1);
	flip(maze, 0, col);
	cnt[0][col] = 0; 
}

int main()
{
	scanf("%d%d", &n, &m);
	for(int i = 0; i < n; i ++){
		for(int j = 0; j < m; j ++){
			scanf("%d", &maze[i][j]);
		}
	}
	dfs(0);
	if(flag){
		for(int i = 0; i < n; i ++){
			for(int j = 0; j < m - 1; j ++){
				printf("%d ", ans[i][j]);
			}
			printf("%d\n", ans[i][m - 1]);
		}
	}
	else printf("IMPOSSIBLE\n");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值