POJ--3279.Fliptile(递推)

Fliptile

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 32918Accepted: 11520

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source

USACO 2007 Open Silver

和之前做过的一个题目特别相像,代码的思路是一样的,主要代码也几乎相同Acwing--95. 费解的开关(递推,位运算)_wowon~的博客-CSDN博客

不同点的话,就是本题需要我们记录一下到底都翻转了哪些点,所以多开两个数组记录一下。ansb来记录在每个方案下的翻转情况,ansa记录最小的翻转次数下的翻转情况。

cnt记录每个方案下翻转的次数。ans记录目前最少的翻转次数

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
const int N=20;
int g[N][N],backup[N][N],ansb[N][N],ansa[N][N];
int n,m;
int dx[6]={0,0,0,-1,1};
int dy[6]={0,1,-1,0,0};
int ans=0x3f3f3f;

void turn(int x,int y)
{
    for(int i=0;i<5;i++)
    {
        int nx=x+dx[i];
        int ny=y+dy[i];
        if(nx>=0&&ny>=0&&nx<n&&ny<m)
        {
            g[nx][ny]^=1;
        }
    }
}
 
 
int workout()
{

    for(int k=0;k<(1<<m);k++)
    {
    	memset(ansb,0,sizeof(ansb));
        memcpy(backup,g,sizeof(g));
        int cnt=0;
        for(int j=0;j<m;j++)
        {
            if((k>>j)&1)
            {
                turn(0,j);
               cnt++;
               ansb[0][j]=1;
            }
        }
        
        for(int i=0;i<n-1;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(g[i][j]==1)
                {
                    turn(i+1,j);
                    cnt++;
                   ansb[i+1][j]=1;
                }
            }
        }
       
        int f=1;//有解
        
        for(int j=0;j<m;j++)
        {
            if(g[n-1][j]==1)
            {
                f=0;
                break;
            }
        }
        if(f&&ans>cnt)
		{
		    ans=cnt;	 
			memcpy(ansa,ansb,sizeof(ansb));
		}
        memcpy(g,backup,sizeof(backup));
    }
}
 
 
int main()
{
   cin>>n>>m;
    for(int i=0;i<n;i++)
	for(int j=0;j<m;j++)
	cin>>g[i][j];
    
    workout();
    if(ans>n*m)
    {
    	cout<<"IMPOSSIBLE"<<endl;
	}
	else
	{
		for(int i=0;i<n;i++)
		{
		 	for(int j=0;j<m;j++)
            cout<<ansa[i][j]<<" ";
            cout<<endl;
		}
		 
	}
   
     
    return 0;
}

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值