Java优先队列

Java优先队列

Java优先队列默认为最小堆

PriorityQueue<Integer> p = new PriorityQueue<Integer>();
for(int i = 1; i <= 10; i ++) p.add(i);
System.out.println(p.poll());

运行结果为1

重写compare函数得到最大堆

static class cmp implements Comparator <Integer>{
		public int compare(Integer a, Integer b) {
			return b - a;
		}
		
PriorityQueue<Integer> q = new PriorityQueue<Integer>(1, new cmp());
for(int i = 1; i <= 10; i ++) q.add(i);
System.out.println(q.poll());

运行结果为10

sort排序
从小到大升序排序

static class cmp implements Comparator <Integer>{
	public int compare(Integer a, Integer b) {
		return a - b;
	}
}

从大到小降序排序

static class cmp implements Comparator <Integer>{
	public int compare(Integer a, Integer b) {
		return b - a;
	}
}

例题

http://acm.hdu.edu.cn/showproblem.php?pid=1896

Stones

Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.

Output
Just output one line for one test case, as described in the Description.

Sample Input
2
2
1 5
2 4
2
1 5
6 6

Sample Output
11
12

Author
Sempr|CrazyBird|hust07p43

Source
HDU 2008-4 Programming Contest

Java代码

import java.util.Scanner;
import java.util.Comparator;
import java.util.PriorityQueue;

public class Main {
	
	public static void main(String[] args) {
		
		Scanner in = new Scanner(System.in);
		int T = in.nextInt();
		while(T -- > 0) {
			PriorityQueue<Node> pq = new PriorityQueue<Node>(1, new cmp());
			int n = in.nextInt();
			int x, y;
			for(int i = 0; i < n; i ++) {
				x = in.nextInt();
				y = in.nextInt();
				pq.add(new Node(x, y));
			}
			int cnt = 1;
			Node now = new Node(0, 0);
			while(!pq.isEmpty()) {
				now = pq.poll();
				if((cnt & 1) == 1) {
					now.pos = now.pos + now.dis;
					pq.add(now);
				}
				cnt ++;
			}
			System.out.println(now.pos);
		}
		
	}
	
	static class cmp implements Comparator<Node> {
		public int compare(Node a, Node b) {
			if(a.pos == b.pos) return a.dis - b.dis;
			else return a.pos - b.pos;
		}
	}
	
	static class Node {
		int pos, dis;
		public Node(int pos, int dis) {
			this.pos = pos;
			this.dis = dis;
		}
	}

}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值