UVa 10115 - Automatic Editing

Problem E: Automatic Editing

Source file:autoedit.{c, cpp, java, pas}
Input file:autoedit.in
Output file:autoedit.out

Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements, within a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below.

RuleFindReplace-by
1.ban bab
2.baba be
3.ana any
4.ba b hind the g

To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of thefind string within the text by the replace-by string, then try to perform the same replacementagain on the new text. Continue until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for afind string, you always start searching at the beginning of the text, (2) once you have finished using a rule (because thefind string no longer occurs) you never use that rule again, and (3) case is significant.

For example, suppose we start with the line

banana boat

and apply these rules. The sequence of transformations is shown below, where occurrences of afind string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and then rule 4 was used once.

 BeforeAfter
 banana boat babana boat
 babana boat bababa boat
 bababa boat beba boat
 beba boat behind the goat

The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of lines, where the first line is the find string and the second line is thereplace-by string. Following all the rules is a line containing the text to edit. For each test case, output a line containing the final edited text.

Both find and replace-by strings will be at most 80 characters long.Find strings will contain at least one character, but replace-by strings may be empty (indicated in the input file by an empty line). During the edit process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.

The first test case in the sample input below corresponds to the example shown above.

Example input:

4
ban
bab
baba
be
ana
any
ba b
hind the g
banana boat
1
t
sh
toe or top
0

Example output:

behind the goat
shoe or shop

题目解析:

本题含义是将前一个串转化为后一个串,当前一个串完全找不到后,再去比较下一个串,直到所有串被替换完毕

本题主要用到的是,string的find()和replace() 方法


#include <string> 
#include <iostream>

using namespace std;
int main()
{
	int cas;

	while(cin>>cas)
	{
		getchar();
		if(cas==0)
			break;
		string search[100],replace[100];
		string str;
		for(int i=0;i<cas;i++)
		{
			getline(cin,search[i]);
			getline(cin,replace[i]);
		}
		getline(cin,str);
		for(int j=0;j<cas;j++)
		{
			string::size_type pos=0;
			while((pos = str.find(search[j],pos)) != string::npos)
			{
				str.replace(pos,search[j].size(),replace[j]);
			}
		}
		cout<<str<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值