Uva-350 Pseudo-Random Numbers


 Pseudo-Random Numbers 

Computers normally cannot generate really random numbers, but frequentlyare used to generate sequences of pseudo-random numbers. These are generatedby some algorithm, butappear for all practical purposes to be really random. Random numbersare used in many applications, including simulation.

A common pseudo-random number generation technique is called the linearcongruential method. If the last pseudo-random number generated was L,then the next number is generatedby evaluating ( tex2html_wrap_inline32 , where Z is a constantmultiplier, I is a constant increment, and M is a constant modulus.For example, suppose Z is 7, I is 5, and M is 12. If the firstrandom number (usually called the seed) is 4, then we can determine thenext few pseudo-random numbers are follows:

tabular21

As you can see, the sequence of pseudo-random numbers generated by thistechnique repeats after six numbers. It should be clear that the longestsequence that can be generated usingthis technique is limited by the modulus, M.

In this problem you will be given sets of values for Z, I, M, and theseed, L. Each of these will have no more than four digits. For each suchset of values you are to determine the lengthof the cycle of pseudo-random numbers that will be generated. But becareful: the cycle might not begin with the seed!

Input

Each input line will contain four integer values, in order, for Z, I, M,and L. The last line will contain four zeroes, and marks the end of theinput data. L will be less than M.

Output

For each input line, display the case number (they are sequentially numbered,starting with 1) and the length of the sequence of pseudo-random numbersbefore the sequence is repeated.

Sample Input

7 5 12 4
5173 3849 3279 1511
9111 5309 6000 1234
1079 2136 9999 1237
0 0 0 0

Sample Output

Case 1: 6
Case 2: 546
Case 3: 500
Case 4: 220


题意:

 L[n] = (Z * L[n-1] + I) mod M,求L[n]的循环周期。L不一定从初值处开始循环。Z,I,M,L都是不大于四位的整数。

解析:

直接模拟当相同的数字出现两次,跳出循环。

#include <stdio.h>
#include <string.h>
const int N = 10010;
int flag[N];
int main() {
	int Z,L,I,M;
	int cas = 1;
	while(scanf("%d%d%d%d",&Z,&I,&M,&L) != EOF) {
		
		if(Z==0 && L==0 && I==0 && M==0)
			break;

		memset(flag,0,sizeof(flag));
		int cut = 0;

		int tmp = L;
		while( ++cut ) {
			tmp = (Z * tmp + I) % M;
			flag[tmp]++;
			if(flag[tmp]==2)
				break;
		}

		printf("Case %d: %d\n",cas++,cut-1);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值