UVA - 112 Tree Summing


 Tree Summing 

Background

LISP was one of the earliest high-level programming languages and, with FORTRAN, is one of the oldest languages currently being used. Lists, which are the fundamental data structures in LISP, can easily be adapted to represent other important data structures such as trees.

This problem deals with determining whether binary trees represented as LISP S-expressions possess a certain property.

The Problem

Given a binary tree of integers, you are to write a program that determines whether there exists a root-to-leaf path whose nodes sum to a specified integer. For example, in the tree shown below there are exactly four root-to-leaf paths. The sums of the paths are 27, 22, 26, and 18.

picture25

Binary trees are represented in the input file as LISP S-expressions having the following form.

empty tree 		 ::= 		 ()

tree ::= empty treetex2html_wrap_inline118 (integer treetree)

The tree diagrammed above is represented by the expression (5 (4 (11 (7 () ()) (2 () ()) ) ()) (8 (13 () ()) (4 () (1 () ()) ) ) )

Note that with this formulation all leaves of a tree are of the form (integer () () )

Since an empty tree has no root-to-leaf paths, any query as to whether a path exists whose sum is a specified integer in an empty tree must be answered negatively.

The Input

The input consists of a sequence of test cases in the form of integer/tree pairs. Each test case consists of an integer followed by one or more spaces followed by a binary tree formatted as an S-expression as described above. All binary tree S-expressions will be valid, but expressions may be spread over several lines and may contain spaces. There will be one or more test cases in an input file, and input is terminated by end-of-file.

The Output

There should be one line of output for each test case (integer/tree pair) in the input file. For each pair I,T (I represents the integer, T represents the tree) the output is the string yes if there is a root-to-leaf path in T whose sum is I and no if there is no path in T whose sum is I.

Sample Input

22 (5(4(11(7()())(2()()))()) (8(13()())(4()(1()()))))
20 (5(4(11(7()())(2()()))()) (8(13()())(4()(1()()))))
10 (3 
     (2 (4 () () )
        (8 () () ) )
     (1 (6 () () )
        (4 () () ) ) )
5 ()

Sample Output

yes
no
yes
no

题目大意:

输入n,再输入由一个二叉树叫你判断,从根到叶子是否存在一个和等于n。

解析:

模拟二叉树的建立过程,如果遇到'('就建立节点。如果遇到')'就判断当前的sum+num是否等于n

如果等于就标记true

注意:要判断负数的情况。

总结,我这题想了好久也没想出来,看了网络上的的题解才明白怎么做。

#include <iostream>
using namespace std;
int n;
bool yes;
char ch;
void dfs(int sum,int &root) {

	cin >> ch;
	bool flag = false;
	int num = 0;

	int left = 1;
	int right = 1;
	//判断是否含有负号	
	if(ch == '-') {
		flag = true;
		cin >> ch;
	}

	while( ch >= '0' && ch <= '9') {
		num = num*10 + (ch - '0');
		root = 0;
		cin >> ch;
	}

	if(flag == true) {
		num = -num;
	}
	//如果遇到'('就建立节点
	if( ch == '(') {
		dfs(sum+num,left);
		cin >> ch;
	}
	if( ch == '(') {
		dfs(sum+num,right);
		cin >> ch;
	}
	if( ch == ')' && left==1 && right==1 && root==false && n==sum+num) {
		yes = true;
	}
}
int main() {
	char ch;
	while(cin >> n) {
		yes = false;
		cin >> ch;
		int root = 1;
		dfs(0,root);
		if(yes) {
			cout<<"yes"<<endl;
		}
		else {
			cout<<"no"<<endl;
		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值