UVA - 11059 Maximum Product (简单枚举)

Problem D - Maximum Product

Time Limit: 1 second

Given a sequence of integers S = {S1, S2, ..., Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that -10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: Case #M: The maximum product is P., where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input

3
2 4 -3

5
2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8.

Case #2: The maximum product is 20.


题目大意:

输入n个元素组成的序列S,你需要找出一个乘积最大的连续子序列。如果这个最大的乘积不是正数,应输出0(表示无解)。1<=n<=18,-10<=Si<=10。

解析:水题一道,直接枚举起点和终点,求最大乘积。注意要用long long


#include <stdio.h>
#include <string.h>

int main() {
	int n;
	int t = 0;
	int cas = 1;
	while(scanf("%d",&n) != EOF) {

		int num[20];
		for(int i = 0; i < n; i++) {
			scanf("%d",&num[i]);
		}
		long long sum;
		long long max = 0;
		for(int i = 0; i < n; i++) { //枚举起点
			for(int j = i ; j < n; j++) { //枚举终点
				sum = 1;
				for(int k = i; k <= j; k++) {
					sum *= num[k];
				}
				if(sum > max) {
					max = sum;
				}
			}
		}
		printf("Case #%d: The maximum product is %lld.\n\n",cas++,max);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值