11059 - Maximum Product



Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the
maximum positive product involving consecutive terms of S. If you cannot find a positive sequence,
you should consider 0 as the value of the maximum product.
Input
Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si
is
an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each
element in the sequence. There is a blank line after each test case. The input is terminated by end of
file (EOF).
Output
For each test case you must print the message: ‘Case #M: The maximum product is P.’, where
M is the number of the test case, starting from 1, and P is the value of the maximum product. After
each test case you must print a blank line.
Sample Input
3
2 4 -3
5
2 5 -1 2 -1
Sample Output
Case #1: The maximum product is 8.
Case #2: The maximum product is 20.


对于每个数,都设置以此数结尾的最大正数pos和最小负数neg,

当data[i]是正数的时候,pos=pos*data[i],neg=neg*data[i]

当data[i]是0的时候,pos=neg=0;

当data[i]是负数的时候,neg*data[i]为最大正数,pos*data[i]就是最小负数,

每次循环更新 maxn;

注意数据范围 用long long

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int data[20];
int main()
{
    int n,num=0;

    while(scanf("%d",&n)!=EOF && n)
    {
        for(int i=1;i<=n;i++)
        scanf("%d",&data[i]);
        long long maxn=0,neg=0,pos=0;
        for(int i=1;i<=n;i++)
        {
            if(data[i]>0)
            {
                pos=pos*data[i];
                neg=neg*data[i];
                if(pos==0)
                    pos=data[i];
            }
            if(data[i]==0)
                pos=neg=0;
            if(data[i]<0)
            {
                long long temp=pos*data[i];
                pos=neg*data[i];
                neg=temp;
                if(neg==0)
                    neg=data[i];
            }
            if(maxn<pos)
                maxn=pos;
        }
        printf("Case #%d: The maximum product is %lld.\n\n",++num,maxn);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值