PAT 1095 Cars on Campus (30)

Zhejiang University has 6 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<= 10000), the number of records, and K (<= 80000) the number of queries. Then N lines follow, each gives a record in the format

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each "in" record is paired with the chronologically next record for the same car provided it is an "out" record. Any "in" records that are not paired with an "out" record are ignored, as are "out" records not paired with an "in" record. It is guaranteed that at least one car is well paired in the input, and no car is both "in" and "out" at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09 

思路:先按车牌排序,找出有效的记录,然后再按时间排序。

程序:

#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <iostream>
#include <map>
using namespace std;
struct node
{
  char plate_number[10];
  int time;
  char status[5];
};
bool cmp(struct node a,struct node b)
{
  if(strcmp(a.plate_number,b.plate_number) != 0)
     return strcmp(a.plate_number,b.plate_number) < 0;
  else return a.time < b.time;
}
bool cmp1(struct node a,struct node b)
{
  return a.time < b.time;
}
int main()
{
  int n,m;
  scanf("%d%d",&n,&m);
  vector<node> v;
  vector<node> tmp;
  for(int i = 0; i < n; i++)
  {
    char s[10];
    int hh,mm,ss;
    char sta[5];
    scanf("%s %d:%d:%d %s",s,&hh,&mm,&ss,sta);
    node temp;
    strcpy(temp.plate_number,s);
    temp.time = hh * 3600 + 60 * mm + ss;
    strcpy(temp.status,sta);
    v.push_back(temp);
  }
  sort(v.begin(),v.end(),cmp);
  map<string,int> parktime;
  int maxtime = 0;
  for(int i = 0; i < v.size() - 1; i++)
  {
    if(strcmp(v[i].plate_number,v[i+1].plate_number) == 0 && strcmp(v[i].status,"in") == 0 && strcmp(v[i+1].status,"out") == 0)
    {
        tmp.push_back(v[i]);
        tmp.push_back(v[i+1]);
        parktime[v[i].plate_number] += v[i+1].time - v[i].time;
        maxtime = max(maxtime,parktime[v[i].plate_number]);
    }
  }
  sort(tmp.begin(),tmp.end(),cmp1);
  int count = 0;
  int now = 0;
  for(int i = 0; i < m; i++)
  {
    int hh,mm,ss;
    scanf("%d:%d:%d",&hh,&mm,&ss);
    while(now < tmp.size() && tmp[now].time <= 3600*hh + 60*mm + ss)
    {
      if(strcmp(tmp[now].status,"in") == 0)
      {
        count++;
      }
      else if(strcmp(tmp[now].status,"out") == 0)
        count--;
      now++;
    }
    printf("%d\n",count);
  }
  map<string,int>::iterator it = parktime.begin();
  for(; it != parktime.end(); it++)
  {
    if(it->second == maxtime)
      printf("%s ",it->first.c_str());
  }
  printf("%02d:%02d:%02d\n",maxtime/3600,maxtime%3600/60,maxtime%60);
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值