A registration card number of PAT consists of 4 parts:
- the 1st letter represents the test level, namely,
T
for the top level,A
for advance andB
for basic; - the 2nd - 4th digits are the test site number, ranged from 101 to 999;
- the 5th - 10th digits give the test date, in the form of
yymmdd
; - finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.
Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤104) and M (≤100), the numbers of cards and the queries, respectively.
Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.
After the info of testees, there are M lines, each gives a query in the format Type Term
, where
Type
being 1 means to output all the testees on a given level, in non-increasing order of their scores. The correspondingTerm
will be the letter which specifies the level;Type
being 2 means to output the total number of testees together with their total scores in a given site. The correspondingTerm
will then be the site number;Type
being 3 means to output the total number of testees of every site for a given test date. The correspondingTerm
will then be the date, given in the same format as in the registration card.
Output Specification:
For each query, first print in a line Case #: input
, where #
is the index of the query case, starting from 1; and input
is a copy of the corresponding input query. Then output as requested:
- for a type 1 query, the output format is the same as in input, that is,
CardNumber Score
. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed); - for a type 2 query, output in the format
Nt Ns
whereNt
is the total number of testees andNs
is their total score; - for a type 3 query, output in the format
Site Nt
whereSite
is the site number andNt
is the total number of testees atSite
. The output must be in non-increasing order ofNt
's, or in increasing order of site numbers if there is a tie ofNt
.
If the result of a query is empty, simply print NA
.
Sample Input:
8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
Sample Output:
Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA
思路:模拟题,不难,照着写就行,一开始写成map有一个样例点超时,觉得实在是没有什么可能改的。。。就把map改成unordered_map,减少了不必要的排序就过...(吐槽一下考点的编译器没有C++11标准>_>)
程序:
#include <cstdio>
#include <vector>
#include <algorithm>
#include <unordered_map>
#include <cstring>
#include <string>
#include <utility>
using namespace std;
struct test
{
string id;
int score;
};
bool cmp(struct test a,struct test b)
{
if(a.score != b.score)
return a.score > b.score;
else
return a.id < b.id;
}
bool cmp1(pair<int,string> a,pair<int,string> b)
{
if(a.first != b.first)
return a.first > b.first;
else
return a.second < b.second;
}
int main()
{
int n,m;
scanf("%d %d",&n,&m);
vector<struct test> v;
for(int i = 0; i < n; i++)
{
char ch[20];
int score;
scanf("%s %d",ch,&score);
struct test temp;
temp.id = ch;
temp.score = score;
v.push_back(temp);
}
for(int i = 0; i < m; i++)
{
int type;
scanf("%d",&type);
if(type == 1)
{
char ch;
scanf(" %c",&ch);
vector<struct test> v1;
for(int j = 0; j < n; j++)
{
if(v[j].id[0] == ch)
v1.push_back(v[j]);
}
printf("Case %d: %d %c\n",i+1,type,ch);
if(v1.size() == 0)
{
printf("NA\n");
continue;
}
sort(v1.begin(),v1.end(),cmp);
for(int j = 0; j < v1.size(); j++)
printf("%s %d\n",v1[j].id.c_str(),v1[j].score);
}
else if(type == 2)
{
char ch1[5];
scanf(" %s",ch1);
string s = ch1;
int tot = 0, count = 0;
for(int j = 0; j < n; j++)
{
string s2 = v[j].id.substr(1,3);
if(s2 == s)
{
tot += v[j].score;
count++;
}
}
printf("Case %d: %d %s\n",i+1,type,ch1);
if(count == 0)
{
printf("NA\n");
continue;
}
printf("%d %d\n",count,tot);
}
else if(type == 3)
{
char ch1[10];
scanf(" %s",ch1);
string s1 = ch1;
unordered_map<string,int> mp;
bool flag = false;
for(int j = 0; j < n; j++)
{
string s2 = v[j].id.substr(4,6);
string s3 = v[j].id.substr(1,3);
if(s2 == s1)
{
//mp[v[j].id.substr(1,3)]++;
mp[s3]++;
flag = true;
}
}
printf("Case %d: %d %s\n",i+1,type,ch1);
if(!flag)
{
printf("NA\n");
continue;
}
unordered_map<string,int>::iterator it = mp.begin();
vector<pair<int,string> > v2;
for(; it != mp.end(); it++)
{
v2.push_back(make_pair(it->second,it->first));
}
sort(v2.begin(),v2.end(),cmp1);
for(int j = 0; j < v2.size(); j++)
{
printf("%s %d\n",v2[j].second.c_str(),v2[j].first);
}
}
}
return 0;
}