A1040 Longest Symmetric String

1040 Longest Symmetric String (25 分)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

解法一:动态规划

#include <cstdio>
#include <iostream>
#include <cstring> 
#include <algorithm>
using namespace std;
const int maxn = 1000 + 10;
int dp[maxn][maxn];  //dp[i][j]表示s[i]至s[j]所表示的子串是否是回文子串,是则为1,不是为0 
char s[maxn];
int main()
{
	cin.getline(s, maxn);
	int len = strlen(s), ans = 1;
	memset(dp, 0, sizeof(dp));
	for(int i=0; i<len; i++){
		dp[i][i] = 1;
		if(i < len-1){
			if(s[i] == s[i+1]){
				dp[i][i+1] = 1;
				ans = 2;  //当前回文子串的长度 
			}
		}
	}
	for(int l=3; l<=len; l++){
		for(int i=0; i+l-1<len; i++){
			int j = i+l-1;
			if(s[i] == s[j] && dp[i+1][j-1] == 1){
				dp[i][j] = 1;
				ans = l;
			}
		}
	}
	printf("%d\n", ans);
	return 0;
}

 解法二:

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值