POJ 3253 Fence Repair

Fence Repair
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 25668 Accepted: 8263

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题意:
有一根木板,切成 n 块,已知最终每块木板长度,求最小花费。每次花费为本次所切木板长度。
分析:
最小花费即每次都切成两个最小长度,例如有长度分别为 6,5,7,4,2 的木板,则最后一次切的长度为 6,切成了4,2。本次未切之前木板为6,5,7,6,同理,倒数第二次未切之前为
11,7,6.倒数第三次未切之前为11,13.总长为24.共花费54.
用优先队列保存每块木板长度,每次从头部取两个最小长度,求和,累加,再加入队列。。。
代码如下:
#include<cstdio>
#include<iostream>
#include<queue>
using namespace std;
int main()
{
    priority_queue<int, vector<int>, greater<int> > q;  //由小到大的优先队列,头部最小
    int n, m;
    while(cin >>n)
    {
        while(!q.empty())  //清空队列
            q.pop();
        while(n--)
        {
            scanf("%d", &m);
            q.push(m);  //加入队列
        }
        long long s = 0;  //数据太大,int就WA了
        while(q.size() > 1)
        {
            int k = q.top();  //先从头部取一个
            q.pop();  //除去头部元素
            k += q.top();  //再从头部取一个,次头为上一个头下面的元素
            q.pop();
            s += (long long)k;
            q.push(k);   //将两最小值的和加入队列
        }
        cout <<s <<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值