POJ3253 Fence Repair

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2…N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

思路

英文题面真难看……
其实就是合并果子啊,没差别
哦,对了 数 组 开 小 见 祖 宗 \color{black}{数组开小见祖宗}
code:

#include<iostream>
#include<map>
using namespace std;
long long h[20005];
long long n;
void swap(int x,int y)
{
	int t;
	t=h[x];
	h[x]=h[y];
	h[y]=t;
	return; 
}
void down(int i)
{
	int t,f=0;
	while (i*2<=n&&f==0)
	{
		if (h[i]>h[i*2]) t=i*2;
		else t=i;
		if (i*2+1<=n)
		{
			if (h[t]>h[i*2+1]) t=i*2+1;
		}
		if (t!=i)
		{
			swap(t,i);
			i=t;
		}
		else f=1;
	}
	return;
}
void jd()
{
	for (int i=n/2;i>=1;i--) down(i);
	return;
}
int zx()
{
	int t;
	t=h[1];
	h[1]=h[n];
	n--;
	down(1);
	return t;
}
void up(int p)
{
  while(p>1)
  {
    if(h[p]<h[p/2])
    {
      swap(h[p],h[p/2]);
      p/=2;
    }
    else break;
  }
}
void cr(int i)
{
	n++;
	h[n]=i;
	up(n);
	return;
}
int main()
{
	cin>>n;
	long long num=n,s=0;
	for (int i=1;i<=n;i++)
	{
		cin>>h[i];
	}
	jd();
	while (n>=2)
	{
		int t=zx(),t2=zx();
		s+=t+t2;
		cr(t+t2);
	}
	cout<<s;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值