HDU 1003 Max Sum

题目链接 DHU 1003

Max Sum

                                                                        Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                                  Total Submission(s): 177991    Accepted Submission(s): 41516


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 

题意:

求最大连续子段和。


分析:

我们用 sum 维护一段连续和,不断更新最大和与他的起点和终点,当 sum < 0 时再让 sum = 0,重新开始计算一段连续

和。


代码:

#include <cstdio>
#include <iostream>
using namespace std;
const int maxn = 100005;
int a[maxn];
int main()
{
    int t, n, cas = 1;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) scanf("%d", &a[i]);
        int Max = a[1], Sta = 1, End = 1, sum = 0, temp = 1;
        for(int i = 1; i <= n; i++)
        {
            sum += a[i];            //sum维护一段连续和
            if(sum > Max)
            {
                Max = sum;          //更新最大和与起点、终点
                Sta = temp;
                End = i;
            }
            if(sum < 0)         //当前的连续和小与0
            {
                sum = 0;        //重新计算
                temp = i + 1;   //从下一个元素开始
            }
        }
        printf("Case %d:\n", cas++);
        printf("%d %d %d\n", Max, Sta, End);
        if(t) printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值