HDU 1677 Nested Dolls

Nested Dolls

                                                              Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                     Total Submission(s): 3164    Accepted Submission(s): 946


Problem Description
Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements?
 

Input
On the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i.
 

Output
For each test case there should be one line of output containing the minimum number of nested dolls possible.
 

Sample Input
  
  
4 3 20 30 40 50 30 40 4 20 30 10 10 30 20 40 50 3 10 30 20 20 30 10 4 10 10 20 30 40 50 39 51
 

Sample Output
  
  
1 2 3 2
 

Source
 

http://acm.hdu.edu.cn/showproblem.php?pid=1677


分析:

有n个盒子,知道宽和高,如果第一个盒子的宽和高是w1,h1,第二个的宽和高是w2,h2,

如果w1<w2 && h1<h2 ,那么第二个盒子就能装下第一个盒子,求最终至少合并成多少个盒子

大家看下面这个数列:

1, 2, 4, 3, 2, 4, 7, 5

它最少可以分为 3 个递增子序列,按贪心分:

第一个:1 2 4 7

第二个:3 4 5

第三个:2

我们也可以逆序求最长上升子序列:2 3 4 它的长度就等于正序至少分成的递增子序列的个数

本题就是贪心+LIS,逆序求最长非递减子序列,为什么非递减?

题中要求盒子的长和宽都不能相同,相同的话就得另要一个盒子,所以我们的序列中元素可以相同

表示另要一个盒子

代码:

#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;
const int MAXN = 20000 + 10;
const int INF = 0x7fffffff;
struct Doll
{
    int w, h;
    bool operator < (const Doll& a) const
    {
        if (w != a.w) return w > a.w; //先按宽降序排列,最后就可以直接正序求高的最长非递减子序列了
        return h < a.h;             //再按高升序排列
    }
} D[MAXN];

int g[MAXN];

int main()
{
    int t, n;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d", &n);
        for (int i = 1; i <= n; i++) g[i] = INF;
        for (int i = 0; i < n; i++) scanf("%d%d", &D[i].w, &D[i].h);
        sort(D, D + n);
        int Max = 0;
        for (int i = 0; i < n; i++)
        {
            int k = lower_bound(g + 1, g + n + 1, D[i].h) - g; //二分法,不然TLE
            while (g[k] == D[i].h) k++;             //可以相同,非递减
            g[k] = D[i].h;
            Max = max(Max, k);
        }

        printf("%d\n", Max);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值