the number of position

Description
Jesse stands in line of n people, but he doesn’t know exactly which position he occupies.

He can say that there are no less than A people standing in front of him and no less than B people standing behind him.

Find the number of different positions Jesse can occupy.

Input
The only line contains three integers n, A and B (0 ≤ A, B < n ≤ 100).

Output

   Print the single number — the number of the sought positions.

Sample Input
Copy sample input to clipboard
10 2 4
Sample Output
4

#include<iostream>
using namespace std;

int main()
{
    int num;
    while(cin >> num){
        int a, b;
        cin >> a >> b ;
        int result = num - a - b;
        cout << result << endl;
    }

    return 0;
}

we know that Jesse stands in line of people, and there are no less than A people standing in front of him, and no less than B people standing behind him.
so when there are exactly A and B in the problem, we can get the max.
then problem is solved

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值