FZU - 2214 Knapsack problem(0 1 背包++)

FZU - 2214    Knapsack problem

Accept: 837    Submit: 3249
Time Limit: 3000 mSec    Memory Limit : 32768 KB

Problem Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

Output

For each test case, output the maximum value.

Sample Input

15 1512 42 21 14 101 2

Sample Output

15

这道题是0-1背包类的问题,但是不同的是这道题的w[i]非常大,最大为1e9,


emmm,先粘一下普通代码:

		for(int i=0;i<n;i++)
			for(int j=0;j<=W;j++)
				if(j<w[i])	dp[i+1][j]=dp[i][j];
				else		dp[i+1][j]=max(dp[i][j],dp[i][j-w[i]]+v[i]);
		printf("%d\n",dp[n][W]);
		

或者:

		for(int i=n-1;i>=0;i--)
			for(int j=0;j<=W;j++)
				if(j<w[i])	dp[i][j]=dp[i+1][j];
				else		dp[i][j]=max(dp[i+1][j],dp[i+1][j-w[i]]+v[i]);
			
		printf("%d\n",dp[0][W]);

这上边的代码时间复杂度是O(nW)

如果做这一道题的话,肯定会超时的啊

所以这一道题DP的对象是价值  v[i]


// 这一道题  DP的对象是价值  v[i] 

//#include<bits/stdc++.h>		//CE
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=505;
const int MAXV=5000+5;
const int INF=0x3f3f3f3f;
int dp[MAXN][MAXV];
int n,b;
int w[MAXN],v[MAXN];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d %d",&n,&b);
		for(int i=0;i<n;i++)	scanf("%d %d",&w[i],&v[i]);
		memset(dp,0x3f,sizeof(dp));
		dp[0][0]=0;
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<=MAXV;j++)
			{
				if(j<v[i])	dp[i+1][j]=dp[i][j];
				else		dp[i+1][j]=min(dp[i][j],dp[i][j-v[i]]+w[i]);
			}
		}
		int res=0;
		for(int i=0;i<=5000;i++)	if(dp[n][i]<=b)	res=i;//这里的 i<=5000 一定要这样 
		printf("%d\n",res);		
	}
	return 0;
}

参考白书,第61页


本人实力有限,如有错误请您指出,谢谢。





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值