UVA - 156 Ananagrams ——STL练习

Most crossword puzzle fans are used to anagrams — groups of words with the same letters in different
orders — for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this
attribute, no matter how you rearrange their letters, you cannot form another word. Such words are
called ananagrams, an example is QUIZ.
Obviously such definitions depend on the domain within which we are working; you might think
that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible
domain would be the entire English language, but this could lead to some problems. One could restrict
the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the
same domain) but NOTE is not since it can produce TONE.
Write a program that will read in the dictionary of a restricted domain and determine the relative
ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be
“rearranged” at all. The dictionary will contain no more than 1000 words.

Input
Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any
number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken
across lines. Spaces may appear freely around words, and at least one space separates multiple words
on the same line. Note that words that contain the same letters but of differing case are considered to
be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line
consisting of a single ‘#’.
Output
Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram
in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always
be at least one relative ananagram.
Sample Input
ladder came tape soon leader acme RIDE lone Dreis peat
ScAlE orb eye Rides dealer NotE derail LaCeS drIed
noel dire Disk mace Rob dries

Sample Output
Disk
NotE
derail
drIed
eye
ladder
soon


题目大意:
输入一些单词,按字典序顺序输出无视大小写及字母顺序后,只出现一次的单词。如 STOP、SOPT、spTO 算重复出现。


#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <map>
#include <set>
#include <vector>
#include <cstring>
using namespace std;

string change(string s)
{
    for(int i=0;i<s.size();i++)
        s[i]=tolower(s[i]);
    sort(s.begin(),s.end());//按字典序排列单词
    return s;
}
int main()
{
    string s;
    map<string ,int > p;//用来统计单词 change 后的次数
    vector<string> ans;//用来保存结果
    vector<string> ve;//用来保存原始单词,因为输出的时候就是原始单词
    while(cin>>s&&s!="#")
    {
        ve.push_back(s);
        p[change(s)]++;
    }
    for(int i=0;i<ve.size();i++)
        if(p[change(ve[i])]==1)//如果单词改变后只出现了一次,那就符合答案
            ans.push_back(ve[i]);
    sort(ans.begin(),ans.end());//排序,按字典序升序排列
    for(int i=0;i<ans.size();i++)
        cout<<ans[i]<<endl;
    return 0;
}

或者

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll MAXN = 2e5+7;
// ll a[MAXN];
struct node{
        int num;
        string s;
        node(){num=0;};//在结构体内部初始化值
        node(int _num, string _s)
        {
                num = _num;
                s = _s;
        }
};
int main()
{
        set<string> se;
        map<string,node> m;
        string str;
        while(cin>>str)
        {
                string c;
                if(str=="#")    break;
                for(int i=0;i<str.size();++i)
                        c += tolower(str[i]);
                sort(c.begin(),c.end());
                m[c] = node(m[c].num+1,str);
        }

        for(map<string,node>::iterator it=m.begin();it!=m.end();++it)
                if(it->second.num==1)   se.insert(it->second.s);
        for(set<string>::iterator it=se.begin();it!=se.end();it++)
                cout<<*it<<endl;
        return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值