POJ 2752 Seek the Name, Seek the Fame——————KMP next 数组的运用

Seek the Name, Seek the Fame

Language:Default
Seek the Name, Seek the Fame
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 24077Accepted: 12558

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Source


找公共前后缀的最大长度
比如第一个样列,
ababcababababcabab a b a b c a b a b a b a b c a b a b
公共前后缀有:

  • ababcababababcabab a b a b c a b a b a b a b c a b a b
  • ababcabab a b a b c a b a b
  • abab a b a b
  • ab a b

长度分别是 18 9 4 2
next数组记录的其实就是最长公共前后缀的长度

next[i]:字符串 0 到 i 的最长公共前后缀的长度

比如这个样列:
ababcababababcabab a b a b c a b a b a b a b c a b a b

inext [ i ]
0next [ 0 ] = -1
1next [ 1 ] = 0
2next [ 2 ] = 0
3next [ 3 ] = 1
4next [ 4 ] = 2
5next [ 5 ] = 0
6next [ 6 ] = 1
7next [ 7 ] = 2
8next [ 8 ] = 3
9next [ 9 ] = 4
10next [ 10 ] = 3
11next [ 11 ] = 4
12next [ 12 ] = 3
13next [ 13 ] = 4
14next [ 14 ] = 5
15next [ 15 ] = 6
16next [ 16 ] = 7
17next [ 17 ] = 8
18next [ 18 ] = 9

得到 next 数组之后,我们从 i=18 开始,
i=18 18next[18]=9 i = 18 记 录   18 n e x t [ 18 ] = 9
i=9 9next[9]=4 i = 9 记 录   9 n e x t [ 9 ] = 4
i=4 4next[4]=2 i = 4 记 录   4 n e x t [ 4 ] = 2
i=2 2next[2]=0 i = 2 记 录   2 n e x t [ 2 ] = 0
i=0 i = 0 结 束

18,9,4,2 18 , 9 , 4 , 2

答案就是2 4 9 18


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<stack>
#include<iostream>
using namespace std;
const int MAXN=400000+7;
char s[MAXN];
int slen,nex[MAXN];

void GetNext()
{
    int i,j;
    i=0;
    j=nex[0]=-1;
    while(i<slen)
    {
        while(-1!=j && s[i] != s[j])    j=nex[j];
        nex[++i]=++j;
    }
}
int main()
{
    while(~scanf("%s", s))
    {
        slen=strlen(s);
        GetNext();
        stack<int> sta;
//        for(int i=0;i<=slen;i++)
//            printf("next[%2d]:%2d\n",i,nex[i]);
        for(int i=slen;~i;i=nex[i])
            if(i>0)
            {
//                printf("next[%2d]:%2d\n",i,nex[i]);
                sta.push(i);
            }
        while(sta.size())
        {
            printf("%d ",sta.top());
            sta.pop();
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值