PTA 甲级1036 Boys vs Girls (25分)

1036 Boys vs Girls (25分)

题目原文

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade**Fgrade**M. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

      
    

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60   

Sample Output 2:

Absent
Jean AA980920
NA

生词

guaranteed 保证

distinct 不同的

题目大意

在M个男生和女生中,找出最低成绩的男生,最高成绩的女生,并且输出他们的分数差

没有就输出Absent ,分数差哪里输出NA

代码如下

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
struct Students {
	char Name[11];
	char ID[11];
	char Sex;
	int Gender;
};
int main(void) {
	struct Students BoyGirl[10000];
	int K, MaxGender=-1, MaxID=-1, MinGender=101, MinID=-1;	//给-1和101是为了让Max和Min都一定可以被取到
	scanf("%d", &K);
	for (int i = 0; i < K; i++) {
		scanf("%s %c %s %d", &BoyGirl[i].Name,
			&BoyGirl[i].Sex, &BoyGirl[i].ID,
			&BoyGirl[i].Gender);
		if (BoyGirl[i].Sex == 'M') {
			if (BoyGirl[i].Gender < MinGender) {
				MinGender = BoyGirl[i].Gender;
				MinID = i;
			}
		}		//判断男孩
		if (BoyGirl[i].Sex == 'F') {
			if (BoyGirl[i].Gender > MaxGender) {
				MaxGender = BoyGirl[i].Gender;
				MaxID = i;
			}
		}	//判断女孩
	}
	if (MaxID != -1)
		printf("%s %s\n", BoyGirl[MaxID].Name, BoyGirl[MaxID].ID);
	else
		printf("Absent\n");
	if (MinID != -1)
		printf("%s %s\n", BoyGirl[MinID].Name, BoyGirl[MinID].ID);
	else
		printf("Absent\n");
	if (MaxID != -1 && MinID != -1) {
		printf("%d", abs(MaxGender - MinGender));
	}
	else
		printf("NA");
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值