PTA甲级 1067 Sort with Swap(0, i) (25分)

首先,先贴柳神的博客

https://www.liuchuo.net/ 这是地址

想要刷好PTA,强烈推荐柳神的博客,和算法笔记

题目原文

1067 Sort with Swap(0, i) (25分)

Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤105) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

生词如下:

nonnegative 非负

题目大意

有一个从0到n-1的数组被打乱了,现在要你重现排列,只能用0来两两交换.现在要你给出最少的交换次数.

题目思路

① 0只要不在开始的位置上,就把0和他位置上的人交换,

② 0一旦回到了开始的位置上,就把0和最近的一个(不是正确的数)交换.

柳神的代码

#include <iostream>
using namespace std;
int main() {
    int n, t, cnt = 0, a[100010];
    cin >> n;
    for (int i = 0; i < n; i++) {
        cin >> t;
        a[t] = i;
    }
    for (int i = 1; i < n; i++) {
        if (i != a[i]) {
            while (a[0] != 0) {
                swap(a[0], a[a[0]]);
                cnt++;
            }
            if (i != a[i]) {
                swap(a[0], a[i]);
                cnt++;
            }
        }
    }
    cout << cnt;
    return 0;
}

反思

① 我又犯了老毛病,复杂的问题简单化,我一开始想的是,交换的次数是一定的,然后就想着不交换偷懒.后来自己手动模拟了才发现,根本不是这样的.

② 交换的此时,以及0回到原文的次数都是不固定的,哪里有那么简单的题目嘛

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值