Mooc浙大数据结构-第一周作业

本篇文章是我学习数据结构的笔记

学习地址如下:

Mooc

参考地址如下:

因本人才疏学浅,如有错留声误之处,还请见谅

01-复杂度1 最大子列和问题 (20分)

柳神的笔记

给定K个整数组成的序列{ N1, N2, …, N**K },“连续子列”被定义为{ N**i, N**i+1, …, N**j },其中 1≤ijK。“最大子列和”则被定义为所有连续子列元素的和中最大者。例如给定序列{ -2, 11, -4, 13, -5, -2 },其连续子列{ 11, -4, 13 }有最大的和20。现要求你编写程序,计算给定整数序列的最大子列和。

本题旨在测试各种不同的算法在各种数据情况下的表现。各组测试数据特点如下:

  • 数据1:与样例等价,测试基本正确性;
  • 数据2:102个随机整数;
  • 数据3:103个随机整数;
  • 数据4:104个随机整数;
  • 数据5:105个随机整数;

输入格式:

输入第1行给出正整数K (≤100000);第2行给出K个整数,其间以空格分隔。

输出格式:

在一行中输出最大子列和。如果序列中所有整数皆为负数,则输出0。

输入样例:

6
-2 11 -4 13 -5 -2

输出样例:

20

代码如下:

#include<iostream>
#include<vector>
using namespace std;
int main(void) {
	int length;
	cin >> length;
	vector<int>Data(length);
	for (int i = 0; i < length; i++) {
		cin >> Data[i];

	}
	int sum = 0,sum_copy = 0;
	for (int i = 0; i < length; i++) {
		sum += Data[i];
		if (sum < 0) {
			sum = 0;
		}
		else if (sum > 0) {
			if (sum > sum_copy) {
				sum_copy = sum;
			}
		}
	}
	printf("%d", sum_copy);
	return 0;
}

01-复杂度2 Maximum Subsequence Sum (25分)

Given a sequence of K integers { N1, N2, …, N**K }. A continuous subsequence is defined to be { N**i, N**i+1, …, N**j } where 1≤ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题目大意:

和上题一摸一样,就是要求输出它最大序列的第一个数,和最后一个数

注意:

① 如果都是负数,要输出第一个数和最后一个数

下面就是Copy柳神的东西了

分析:sum为要求的最大和,temp为临时最大和,leftindex和rightindex为所求的子序列的下标,tempindex标记left的临时下标~

temp = temp + v[i],当temp比sum大,就更新sum的值、leftindex和rightindex的值;当temp < 0,那么后面不管来什么值,都应该舍弃

temp < 0前面的内容,因为负数对于总和只可能拉低总和,不可能增加总和,还不如舍弃~

舍弃后,直接令temp = 0,并且同时更新left的临时值tempindex。因为对于所有的值都为负数的情况要输出0,第一个值,最后一个值,

所以在输入的时候用flag判断是不是所有的数字都是小于0的,如果是,要在输入的时候特殊处理~

代码如下:

#include <iostream>
#include <vector>
using namespace std;
int main() {
    int n;
    scanf("%d", &n);
    vector<int> v(n);
    //leftindex就是左下标,rightindex就是右下标
    //temp就是sum的临时变量
    //tempindex就是临时的左下标
    int leftindex = 0, rightindex = n - 1, sum = -1, temp = 0, tempindex = 0;
    for (int i = 0; i < n; i++) {
        scanf("%d", &v[i]);

        temp = temp + v[i];
        if (temp < 0) {
            temp = 0;
            tempindex = i + 1;
        }
        else if (temp > sum) {
            sum = temp;
            leftindex = tempindex;
            rightindex = i;
        }
    }
    if (sum < 0) sum = 0;
    printf("%d %d %d", sum, v[leftindex], v[rightindex]);
    return 0;
}

01-复杂度3 二分查找 (20分)

本题要求实现二分查找算法。

函数接口定义:

Position BinarySearch( List L, ElementType X );

其中List结构定义如下:

typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

L是用户传入的一个线性表,其中ElementType元素可以通过>、==、<进行比较,并且题目保证传入的数据是递增有序的。函数BinarySearch要查找XData中的位置,即数组下标(注意:元素从下标1开始存储)。找到则返回下标,否则返回一个特殊的失败标记NotFound

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

#define MAXSIZE 10
#define NotFound 0
typedef int ElementType;

typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

List ReadInput(); /* 裁判实现,细节不表。元素从下标1开始存储 */
Position BinarySearch( List L, ElementType X );

int main()
{
    List L;
    ElementType X;
    Position P;

    L = ReadInput();
    scanf("%d", &X);
    P = BinarySearch( L, X );
    printf("%d\n", P);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例1:

5
12 31 55 89 101
31

输出样例1:

2

输入样例2:

3
26 78 233
31

输出样例2:

0

代码如下:

Position BinarySearch(List L, ElementType X) {
    int begin = 1, end = L->Last,mid=0;
    while (begin <= end) {
        mid = (begin + end) / 2;
        if (X == L->Data[mid]) {
            return mid;
        }
        else if (X < L->Data[mid]) {
            end = mid - 1;
        }
        else
            begin = mid + 1;
    }
    return NotFound;
}

结尾:

鸡汤时间:

我才22岁,可以成为任何我想成为的人

如果这篇文章对你有张帮助的话,可以用你高贵的小手给我点一个免费的赞吗

相信我,你也能变成光.

在这里插入图片描述

如果你有任何建议,或者是发现了我的错误,欢迎评论留言指出.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值