PTA甲级 1024 Palindromic Number (25分)-回文 大整数计算


强烈推荐,刷PTA的朋友都认识一下柳神–PTA解法大佬

本文由参考于柳神博客写成

柳神的CSDN博客,这个可以搜索文章

柳神的个人博客,这个没有广告,但是不能搜索

PS 今天也是充满希望的一天.

在这里插入图片描述

题目原文

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤1010) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

生词如下:

palindromic 回文数

题目大意:

就是给你一个数字,和步长

判断这个数字是不是回文数.如果不是的话

要求这个数字+这个数字的逆置 比如 123 不是回文数,我们需要的就是 123+321=444

444 是回文数,所以结束,步长是1 输出结果

如果结果不是回文数的话,继续,直到步长用完.

输出结果

思路如下:

它给的可能是高精度的数.

我用的是string来存储.

然后逆置回文数和判断回文数都用的是string的特性.

然后算加法的时候,会比较麻烦一点.但是都是高精度那一套.

注意不要忘记进位就OK了.

我的代码如下:

#include<iostream>
#include<string>
#include<cstring>
#include <algorithm>
#include <stdlib.h>
using namespace std;
//判断回文数
bool isPalindromic(string b) {
	bool palindromic = true;
	int size = b.length() / 2;
	for (int i = 0; i <size; i++) {
		if (b[i] != b[b.length() - 1 - i]) {
			palindromic = false;
			break;
		}
	}
	return palindromic;
}
//返回回文数
string Reverse(string a) {
	reverse(a.begin(), a.end());
	return a;
}
//两个string 数相加
string add(string a, string b) {
	string c;
	int carry = 0,t=0,index=0;
	for (int i = a.length() - 1; i >= 0; --i) {
		t = (a[i] - '0') + (b[i] - '0');
		if (t + carry >= 10) {
			c+=to_string((t + carry) % 10);
			carry = 1;
		}
		else {
			c += to_string((t + carry));
			carry = 0;
		}
	}
	if (carry == 1)	c += to_string(1);
	reverse(c.begin(), c.end());
	return c;
}
int main(void) {
	string a;
	int step = 0, t = 0;
	cin >> a >> step;
	t = step;
	while (!(isPalindromic(a) || step == 0)) {
		string b = Reverse(a);
		a = add(a, b);
		step--;
	}
	cout << a << "\n" << t-step;
	return 0;
}

下面和我一起欣赏柳神的代码 吧

柳神代码如下:

柳神比我好的地方,就是她是没有存储反转后的值的,当然,也确实不需要存储反转后的值.

柳神就是厉害.

#include <iostream>
#include <algorithm>
using namespace std;
string s;
//这个加法的代码写比我好多多多了.学习了.
void add(string t) {
    int len = s.length(), carry = 0;
    for (int i = 0; i < len; i++) {
        s[i] = s[i] + t[i] + carry - '0';
        carry = 0;
        if (s[i] > '9') {
            s[i] = s[i] - 10;
            carry = 1;
        }
    }
    if (carry) s += '1';
    reverse(s.begin(), s.end());
}
int main() {
    int cnt, i;
    cin >> s >> cnt;
    for (i = 0; i <= cnt; i++) {
        string t = s;
        //判断的代码写的也好.
        reverse(t.begin(), t.end());
        if (s == t || i == cnt) break;
        add(t);
    }
    cout << s << endl << i;
    return 0;
}

如果这篇文章对你有张帮助的话,可以用你高贵的小手给我点一个免费的赞吗

相信我,你也能变成光.

在这里插入图片描述

如果你有任何建议,或者是发现了我的错误,欢迎评论留言指出.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值