PTA甲级 1047 Student List for Course (25分)


强烈推荐,刷PTA的朋友都认识一下柳神–PTA解法大佬

本文由参考于柳神博客写成

柳神的CSDN博客,这个可以搜索文章

柳神的个人博客,这个没有广告,但是不能搜索

PS 今天也要加油鸭

在这里插入图片描述

题目原文

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

生词如下:

alphabetical

题目大意:

给你学生姓名和课程人数.

还有每个学生上什么课.问你每个课有多少学生上.各有多少人.

思路如下:

我们用一个vector用来保存学生.

用一个char 的二维数组来保存姓名.

然后就是正常的寻找,输出.

代码如下:

#include<iostream>
#include<vector>
#include<cstring>

#include <algorithm>
using namespace std;
char name[50000][5];
vector<int> course[2520];
bool cmp1(int a, int b) {
	return strcmp(name[a], name[b]) < 0;
}
int main(void) {
	int n, k;
	scanf("%d%d", &n, &k);
	for (int i = 0; i < n; ++i) {
		int course_cnt = 0;
		scanf("%s%d", name[i], &course_cnt);
		for (int j = 0; j < course_cnt; ++j) {
			int t = 0;
			scanf("%d", &t);
			course[t].push_back(i);
		}
	}
	for (int i = 1; i <=k; ++i) {
		if (i != 1)	printf("\n");
		printf("%d %d", i, course[i].size());
		sort(course[i].begin(), course[i].end(), cmp1);
		for (int j = 0; j < course[i].size(); j++) {
			printf("\n%s", name[course[i][j]]);
		}
	}
	return 0;
}

如果这篇文章对你有张帮助的话,可以用你高贵的小手给我点一个免费的赞吗

相信我,你也能变成光.

在这里插入图片描述

如果你有任何建议,或者是发现了我的错误,欢迎评论留言指出.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值