HDU 1242 Rescue(求最短时间救出同伴,BFS+DP)





Rescue
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. 

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards. 

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.) 
 

Input

First line contains two integers stand for N and M. 

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file. 
 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input

     
     
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output

     
     
13
 

题目大意:

你的朋友被抓进监狱,现在你要找到你的朋友,在途中你会遇到墙(’#‘),不能走,路(‘.’)可以走,花时为1秒,士兵(‘X’),花时间为2秒,求最短时间。

解题思路:

BFS和DP,不能单纯的只用BFS,因为有的一步是要花时间2,有的为1,不能确保当前的就是最优的,所有有要用到DP。



代码;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>

using namespace std;

struct node{
    int i,j;
    node(int i0=0,int j0=0){
        i=i0,j=j0;
    }
};

const int dirJ[4]={0,1,0,-1};
const int dirI[4]={1,0,-1,0},maxN=220;
int n,m,is,js,ie,je,time[maxN][maxN];
char str[maxN][maxN];

void bfs(){
    queue <node> path;
    time[is][js]=0;
    path.push(node(is,js));
    while(!path.empty()){
        node s=path.front();
        path.pop();
        for(int k=0;k<4;k++){
            int di=s.i+dirI[k],dj=s.j+dirJ[k];
            if(di>=n||dj>=m||di<0||dj<0) continue;
            if(str[di][dj]=='#') continue;
            int tmp=time[s.i][s.j]+1;
            if(str[di][dj]=='x') tmp++;
            if( tmp<time[di][dj] || time[di][dj]==-1 ){//带点dp优化.
                path.push(node(di,dj));
                time[di][dj]=tmp;
            }
        }
    }
    if(time[ie][je]==-1) printf("Poor ANGEL has to stay in the prison all his life.\n");
    else printf("%d\n",time[ie][je]);
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        memset(time,-1,sizeof(time));
        for(int i=0;i<n;i++){
            scanf("%s",str[i]);//建议这样。
            for(int j=0;j<m;j++){
                if(str[i][j]=='r'){is=i,js=j;}
                if(str[i][j]=='a'){ie=i,je=j;}
            }
        }
        bfs();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值