hdu 5775



Bubble Sort

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 938    Accepted Submission(s): 549


Problem Description
P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.
for(int i=1;i<=N;++i)
    for(int j=N,t;j>i;—j)
        if(P[j-1] > P[j])
            t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.
 

Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.
 

Sample Input
  
  
2 3 3 1 2 3 1 2 3
 

Sample Output
  
  
Case #1: 1 1 2 Case #2: 0 0 0
Hint
In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3) the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3 In second case, the array has already in increasing order. So the answer of every number is 0.
 
题目意思很简单,就是判断每个数字在冒泡排序中的最左最右位置。由于排序是从后向前排的,所以对于每个数,它所能右移的位置数就是它右边的比自己小的数字的个数。所以问题就转换成了如何求每个数右边比自己小的数字的个数。由于数据范围是10w,因此不能直接模拟。所以应该用树状数组来进行维护。从右向左扫一遍,扫到相应数字时候就放入树状数组里。

#include<iostream>
#include<stdlib.h>
#include<string>
#include<vector>
#include<string.h>

using namespace std;
int n;
int tree[100010];
void add(int k,int num){
	while(k<=n){
		tree[k]+=num;
		k+=k&-k;
	}

}
int Sum(int k){
	int sum=0;
	while(k){
		sum+=tree[k];
		k-=k&-k;
	}
	return sum;
}
int a[100010];
int l[100010];
int r[100010];
int main(){
#ifdef LOCAL
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
#endif
	int T;
	cin>>T;
	int Case=0;
	while(T--){
		Case++;
		cin>>n;
		memset(tree,0,sizeof(tree));
		for(int i=1;i<=n;i++){
			cin>>a[i];
		}
		for(int i=n;i>=1;i--){
			l[a[i]]=min(a[i],i);
			r[a[i]]=i+Sum(a[i]);
			add(a[i],1);
		}
		cout<<"Case #"<<Case<<":";
		for(int i=1;i<=n;i++){
			cout<<" "<<r[i]-l[i];
		}
		cout<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值