【HDU5775】【树状数组】Bubble Sort 题解

Bubble Sort

P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.

for(int i=1;i<=N;++i)
for(int j=N,t;j>i;―j)
if(P[j-1] > P[j])
t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.
Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.
Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.
Sample Input
2
3
3 1 2
3
1 2 3
Sample Output
Case #1: 1 1 2
Case #2: 0 0 0

Hint

In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3)
the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3
In second case, the array has already in increasing order. So the answer of every number is 0.

先开始直接for loop大暴力,TLE
后来发现可以树状数组优化,AC

附AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <string>
#include <iomanip>
#include <ctime>
#include <climits>
#include <cctype>
#include <algorithm>
#define clr(x) memset(x,0,sizeof(x))
#define LL long long
#ifdef WIN32
#define AUTO "%I64d"
#else
#define AUTO "%lld"
#endif

using namespace std; 

const int maxn = 100005;
const int maxm = 1000005;
int t,n;
int cnt,l,r,nx,x;
int num[maxn<<1],ans[maxn<<1];
int f[maxn<<1];

int lowbit(int x) { return x&(-x); }

void update(int x) {
    while(x<=n) {
        f[x]++;
        x += lowbit(x);
    }
}

int get(int x) {
    int t = 0;
    while(x != 0) {
        t += f[x];
        x -= lowbit(x);
    }
    return t;
}

int main() {
    scanf("%d",&t);
    for(int z = 1; z <= t; z++) {
        scanf("%d",&n); clr(f);
        for(int i = 1; i <= n; i++)  scanf("%d",&num[i]);
        cnt = l = r = nx = x = 0;
        for(int i = 1; i <= n; i++) {
            update(num[i]);
            nx = i-get(num[i]);
            x = num[i]+nx-i;
            l = min(i, num[i]);
            r = max(i, i+x);
            ans[num[i]] = abs(r-l);
        }
        printf("Case #%d:",z);
        for(int i = 1; i <= n; i++) printf(" %d",ans[i]);
        printf("\n"); 
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值