POJ-1751 Highways (最小生成树)

Highways
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16471 Accepted: 4824 Special Judge

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3
题意:在城市之间建立公路是每个城市之间都有路可达,求最短需要建多长的公路,输出所建公路两端的城市;

输入:n个城市的坐标,其中有m条路已经建成;

思路:最小生成树,算出任意两个城市之间的距离(不需要开根),把已经有路的城市之间的距离设为0,另外需要一个数组记录纵             坐标,方便输出坐标;

代码:

#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f

struct Town//城镇坐标
{
    int x,y;
} a[1010];

int n;
int e[1010][1010],dis[1010],book[1010],p[1010];

void prim()
{
    int i,j,k,l;
    for(i=1; i<=n; i++)
    {
        dis[i]=e[1][i];//初始化dis数组,这里是1号顶点到各个顶点的初始距离,因为当前生成树中只有1号顶点
        p[i]=1;//开始纵坐标全是1;
    }
    book[1]=1;//标记1个顶点是否加入生成树

    for(l=1; l<n; l++)
    {
        int minn=INF;
        for(i=1; i<=n; i++)
        {
            if(book[i]==0&&dis[i]<minn)
            {
                minn=dis[i];
                j=i;
            }
        }
        book[j]=1;

        if(e[p[j]][j]!=0)
            printf("%d %d\n",p[j],j);

        for(k=1; k<=n; k++)
        {
            if(book[k]==0&&dis[k]>e[j][k])//扫描当前顶点j所有边,再以j为中间点,更新生成树到每个非树顶点的距离
            {
                dis[k]=e[j][k];
                p[k]=j;//接下来的所有点的纵坐标为j;
            }
        }
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        int i,j,k;
        memset(book,0,sizeof(book));
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
                if(i==j)
                    e[i][j]=0;
                else
                    e[i][j]=INF;
        }

        for(i=1; i<=n; i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
        }

        for(i=1; i<=n; i++)
        {
            for(j=1; j<=i; j++)
            {
                int s=(a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y);//两点间距离的平方
                e[i][j] = s;//无向图
                e[j][i] = s;
            }
        }
        int q,u,v;
        scanf("%d",&q);
        for(i=0; i<q; i++)
        {
            scanf("%d%d",&u,&v);
            e[u][v]=0;//无向图
            e[v][u]=0;//两个必须写
        }

        prim();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值