Highways-最小生成树

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can’t reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.
Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.
Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.
Sample Input

9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2
Sample Output

1 6
3 7
4 9
5 7
8 3

思路:这是一道最小生成树模板题只不过有一点小改动,需要注意的是输出顺序可以和样例不一样。
代码:

#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
int f[1010];
struct l
{
	int t1,t2;
	double t3;
} stud[400100];
bool myy(l x,l y)
{
	return x.t3<y.t3;
}
void my(int n)
{
	int i;
	//printf("1\n");
	for(i=1; i<=n; i++)
	{
		f[i]=i;
	}
}
int my1(int u)
{
	if(f[u]==u)
	{
		return f[u];
	}
	else
	{
		f[u]=my1(f[u]);
		return f[u];
	}
}
void my2(int a,int b)
{
	int t1,t2;
	t1=my1(a);
	t2=my1(b);
	if(t1!=t2)
	{
		f[t2]=t1;
	}
}
int main()
{
	double x[2000],y[2000];
	int n,i,j,t=0,m;
	scanf("%d",&n);
	my(n);
	for(i=1; i<=n; i++)
	{
		scanf("%lf %lf",&x[i],&y[i]);
	}//首先我们先给这些地方一个编号并计算出任意两个之间的距离然后进行排序
	for(i=1; i<=n; i++)
	{
		for(j=i+1; j<=n; j++)
		{
			stud[t].t1=i;
			stud[t].t2=j;
			stud[t].t3=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]))*1.0;
			t++;
		}
	}
	sort(stud,stud+t,myy);
	scanf("%d",&m);
	int p=0,k=0;
	for(i=0; i<m; i++)
	{
		int a,b;
		scanf("%d %d",&a,&b);
		if(my1(a)!=my1(b))//这里先计算出有多少条路是已经连好了
		{
			p++;
		}
		my2(a,b);
	}
	if(p==n-1) printf("\n");//如果右N-1条的话那就已经全部连通了直接输出换行
	else
	{
		for(i=0; i<t; i++)
		{
			if(my1(stud[i].t1)!=my1(stud[i].t2))
			{
				my2(stud[i].t1,stud[i].t2);
				printf("%d %d\n",stud[i].t1,stud[i].t2);
				p++;
				if(p==n-1) break;
			}
		}
	}
return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值