HDU-1051-Wooden Sticks(C++ && 不水的贪心!)

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14161    Accepted Submission(s): 5860


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1052  1045  1009  1053  1789 


今天是端午节,祝各位C友端午节安康!好!废话不多说,开始我们的每日一水时间!
终于来了一道不是那么水的题了,首先解释一下题目的大意:

题目大意:
给你n根木棍的长度和重量。根据要求求出制作该木棍的最短时间。建立第一个木棍需要1分钟,如果接着制作的木棍比这个木棍的长度长,重量要重,那么接着制作的木棍不需要花费时间!然后如果再继续接着制作,则下一个木棍要比上一个木棍的长度长,重量大,则这个木棍也不需要花费时间!依次类推,反之,则需要花费一分钟,然后让你求出制作这一批木棍花费的最少的时间是多少!

解题思路:
其实大概明白了题意,便可以知道,这题考的是贪心!然后关键就在于贪心策略的选择!题目说了求最小时间,那就肯定要求长度和重量都要相对来说最小,我的策略如下:


1.首先按照木棍的长度进行排序,如果长度相等则重量重的放在前面。
2. 当然 排序完后,不一定都是下一根木棍重量和长度都大于前一根的,但是我们可以根据排序建立的数组再进行多次扫描,比较。
3.根据建立的数组依次比较他们的重量,如果大于标记数组跳过,否则ans加1。


#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 5010;
struct stick
{
    int length;
    int weight;
    bool vis;
};
bool cmp(stick s1,stick s2)
{
    if(s1.length==s2.length)
        return s1.weight<s2.weight;
    else
        return s1.length<s2.length;
}
int n;
stick s[maxn];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&s[i].length,&s[i].weight);
            s[i].vis = false;
        }

        sort(s,s+n,cmp);
        int ans = 0;

        for(int i=0;i<n;i++)
        {
            if(!s[i].vis)
            {
                s[i].vis=true;
                ++ans;
                int weight = s[i].weight;
                for(int j=i+1;j<n;j++)
                {
                    if(!s[j].vis && s[j].weight>=weight)
                    {
                        s[j].vis = true;
                        weight = s[j].weight;
                    }
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}



 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值