HDOJ1002

/*
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input

2
1 2
112233445566778899 998877665544332211
Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
*/

#include<iostream>//高精度加法
#include<cstring>
#define MAX 1004
using namespace std;
int main(){
    int a_length,b_length;//a,b的长度
    int len,x,t=0;//len是sum数组长度,x是进位
    int i[MAX],j[MAX];//转存成数字数组
    char a[MAX],b[MAX];//为了好输入呀
    int sum[MAX];//相加结果数组
    int testnumber;//有几组测试数据
    cin>>testnumber;
    for(int p=1;p<=testnumber;p++){
        memset(i,0,sizeof(i));
        memset(j,0,sizeof(j));
        memset(sum,0,sizeof(sum));
    //    memset(a,0,sizeof(a));
    //    memset(b,0,sizeof(b));
        if(t>0) cout<<endl;
        cin>>a; cin>>b;
        a_length=strlen(a);
        b_length=strlen(b);
        
        for(int k=0;k<a_length;k++)
            i[a_length-k]=a[k]-48;
        for(int k=0;k<b_length;k++)
            j[b_length-k]=b[k]-48;
            
        len=0;
        x=0;
        
        while(len<=a_length||len<=b_length){
            sum[len]=i[len]+j[len]+x;
            x=sum[len]/10;
            sum[len]=sum[len]%10;
            len++;
        }
        
        sum[len]=x;
        if(x==0) len--;
        if(sum[len]) t++;            
        cout<<"Case "<<p<<":"<<endl;
        for(int jj=0;jj<a_length;jj++) cout<<a[jj];
        cout<<" "<<"+"<<" ";
        for(int jj=0;jj<b_length;jj++) cout<<b[jj];
        cout<<" "<<"="<<" ";
        for(int jj=len;jj>0;jj--) cout<<sum[jj];
        cout<<endl;
    }
    return 0;

}

其实就是高精度加法吧,然后我半天格式错误,因为题目要非第一次输入的时候在输入前面有个回车,这就是t的用处啦

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值