树的遍历

L2-006. 树的遍历

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
 


这道题主要是考察树的建立以及遍历,可以开数组模拟树,记住左结点的是root * 2 右结点顺序是root * 2 + 1,根都放在了tree里然后按前序遍历输出tree里的根就好,先从后序遍历找到第一个根然后在从中序遍历里面找到根的位置,判断左右子树,然后递归建立子树就可以,总而言之是挺简单的一道水题!!!!!!!


# include <iostream>
# include <string>
# include <vector>
# include <algorithm>
# include <map>
# include <set>
# include <cstdio>
# include <iomanip>
# include <functional>
# include <cstring>
# include <cmath>
# include <queue>

using namespace std;

const int maxn = 3005;
int tree[maxn];

//递归建树
void build(int rt, vector<int>a, vector<int> b)
{
  if(a.size() == 0)
  {
  //  cout << "exit" << endl;
    return ;
  }
  //找根、
  //后序遍历是左右根,意思是最后一个数据是根
  //中序是左根右,前序是根左右
  int p = 0;
  for(int i = 0; i < b.size(); i++)
  {
    if(b.at(i) == a.at(a.size() - 1))
    {
      p = i;
    }
  }
  vector<int> al, ar, bl, br;
  //把根的位置保存下来然后左右子树遍历存起来
  //左子树的后序遍历序列
  for(int i = 0; i < p; i++)
  {
    al.push_back(a.at(i));
  }
  //右子树的后序遍历序列
  for(int i = p; i < a.size() - 1; i++)
  {
    ar.push_back(a.at(i));
  }

  //左子树的中序遍历序列
  for(int i = 0; i < p; i++)
  {
    bl.push_back(b.at(i));
  }
  //右子树的中序遍历序列
  for(int i = p + 1; i < b.size(); i++)
  {
    br.push_back(b.at(i));
  }
  tree[rt] = b.at(p);//建根
  build(rt *2, al, bl);//递归建左子树
  build(rt * 2 + 1, ar, br);//递归建右子树
}

//用Bfs层次遍历
void bfs()
{
  queue<int> q;
  int root = 1;
  q.push(root);
  int f = 0;
  while(!q.empty())
  {
    if(f++)
    {
      cout << " ";
    }
    root = q.front();
    cout << tree[root];
    q.pop();
    if(tree[root * 2] != -1)
    {
      q.push(root*2);
    }
    if(tree[root * 2 + 1] != -1)
    {
      q.push(root * 2 + 1);
    }
  }
  cout << endl;
}

int main(int argc, char *argv[])
{
  int n, x;
  while(cin >> n)
  {
    memset(tree, -1, sizeof(tree));
    vector<int>a, b;
    //后序遍历
    for(int i = 0; i < n; i++)
    {
      cin >> x;
      a.push_back(x);
    }
    //中序遍历
    for(int i = 0; i < n; i++)
    {
      cin >> x;
      b.push_back(x);
    }
    build(1, a, b);
    bfs();
  }
  return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值