结构与算法 7-23 还原二叉树 (25 分)(30行精简 队列构造)

7-23 还原二叉树 (25 分)

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

输入格式:

输入首先给出正整数N(≤50),为树中结点总数。下面两行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区别大小写)的字符串。

输出格式:

输出为一个整数,即该二叉树的高度。

输入样例:

9
ABDFGHIEC
FDHGIBEAC

输出样例:

5
#include <iostream>
#include <string>
#include <queue>
using namespace std;
struct Order {
	string pre, mid;
}raw;
int main() {
	int n, count = 0;
	cin >> n >> raw.pre >> raw.mid;
	queue<Order> tree;
	tree.push(raw);
	while (!tree.empty()) {
		int size = tree.size();
		for (int i = 0; i < size; i++) {		//层序遍历
			Order& od = tree.front();
			int index = od.mid.find(od.pre[0]);
			if (index != 0) {
				Order left{ od.pre.substr(1,index), od.mid.substr(0,index) };
				tree.push(left);
			}
			if (index != od.mid.size() - 1) {
				Order right{ od.pre.substr(index + 1,string::npos), od.mid.substr(index + 1,string::npos) };
				tree.push(right);
			}		tree.pop();
		}
		count++;
	}
	cout << count;
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值