指针当形参

Problem : 指针当形参

Description

下面的程序将调用函数进行变量的交换,请设计出交换的函数
#include <iostream>
using namespace std;
void jiaohuan(int *p1, int *p2);
int main( )
{
    int a,b;
    cin>>a>>b;
    jiaohuan(&a,&b);
    cout<<a<<" "<<b<<endl;
    return 0;
}
//下面定义jiaohuan;

Input

两个整数

Output

输入数据交换顺序后的结果

Sample Input

100 10

Sample Output

10 100


/*
 *Copyright(c)2014,烟台大学计算机学院
 *All rights reserved.
 *文件名称:test.cpp
 *作者: 杨汉宁
 *完成日期:2014年 12月 8日
 *版本号:v1.0
 *
 *问题描述:用指针交换两数
 *程序输入:
 *程序输出:
 */
#include <iostream>
using namespace std;
void FX(int *p1, int *p2);
int main( )
{
    int a,b;
    cin>>a>>b;
    FX(&a,&b);
    cout<<a<<" "<<b<<endl;
    return 0;
}
void FX(int *p1, int *p2)
{
    int *temp;
    temp=new int;
    *temp=*p1;
    *p1=*p2;
    *p2=*temp;
    delete temp;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值