HDU 1698-Just a Hook(线段树区间更新)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 37795    Accepted Submission(s): 18414
原题地址: http://acm.hdu.edu.cn/showproblem.php?pid=1698

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
 
 
11021 5 25 9 3
 
Sample Output
 
 
Case 1: The total value of the hook is 24.
 

Source

题目大意:一个区间,开始区间的所有值都是一,然后按照要求修改不同区间的值,并把这个区间的值都变成另外一个值,输入前两个数为区间,最后一个为把这个区间修改值的命令(1改为1,2改为2,3改为3),显然这是一道线段树区间更新的题!想更好的理解我的代码,建议看下 线段数树单点更新线段树区间更新的代码,便于理解!

AC代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<time.h>
#include<map>
#include<string>
#include<algorithm>
#include<set>
#define N 50000

using namespace std;

int a;

struct node
{
    int L;
    int R;
    int num;
    int lazy;
    int lenth;
}leaves[100000<<2];

void Push_Tree(int k)
{
    if(leaves[k].lazy)
    {
        leaves[2*k].num = leaves[k].lazy*leaves[2*k].lenth;
        leaves[2*k+1].num = leaves[k].lazy*leaves[2*k+1].lenth;
        leaves[2*k].lazy = leaves[k].lazy;
        leaves[2*k+1].lazy = leaves[k].lazy;
        leaves[k].lazy = 0;
    }
}

void Build_Tree(int l, int r, int k)
{
    leaves[k].L = l;
    leaves[k].R = r;
    leaves[k].lazy = 0;
    leaves[k].lenth = r - l + 1;
    if(l == r){
        leaves[k].num = 1;
        return;
    }
    int mid = (l+r)/2;
    Build_Tree(l, mid, 2*k);
    Build_Tree(mid+1, r, 2*k+1);
    leaves[k].num = leaves[2*k].num+leaves[2*k+1].num;
}

void Update_Tree(int l, int r, int add, int k)
{
    if(leaves[k].L == l && leaves[k].R == r){
        leaves[k].num = leaves[k].lenth * add;
        leaves[k].lazy = add;
        return;
    }
    Push_Tree(k);
    int mid = (leaves[k].L+leaves[k].R)/2;
    if(r <= mid) Update_Tree(l, r, add, 2*k);
    else if(l > mid)Update_Tree(l, r, add, 2*k+1);
    else{
        Update_Tree(l, mid, add, 2*k);
        Update_Tree(mid+1, r, add, 2*k+1);
    }
    leaves[k].num = leaves[2*k].num + leaves[2*k+1].num;
}

int Search_Tree(int l, int r, int k)
{
    if(leaves[k].L == l && leaves[k].R == r){
        return leaves[k].num;
    }
    Push_Tree(k);
    int mid = (leaves[k].L+leaves[k].R)/2;
    if(r <= mid) return Search_Tree(l, r, 2*k);
    else if(l > mid) return Search_Tree(l, r, 2*k+1);
    else{
        return Search_Tree(l, mid, 2*k) + Search_Tree(mid+1, r, 2*k+1);
    }
}

int main()
{
    int m, n, T, x, y, s, z = 1;
    scanf("%d", &T);
    while(T--){
        scanf("%d", &n);
        Build_Tree(1, n, 1);
        scanf("%d", &m);
        while(m--){
            scanf("%d%d%d", &x, &y, &s);
            Update_Tree(x, y, s, 1);
        }
        printf("Case %d: The total value of the hook is %d.\n", z++, Search_Tree(1, n, 1));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值