HDU1698-Just a Hook(线段树 区间更新 lazy标记)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1698

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
http://acm.hdu.edu.cn/data/images/C116-1010-1.JPG

Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1

10

2

1 5 2

5 9 3

Sample Output

Case 1: The total value of the hook is 24.


题目大意:

一个初始值为1的数组,对数组进行区间更新,可以选择一段区间更新为1或2或3,最后求数组之和。

lazy标记:

每一个结点都维护了一段区间,当update修改了这部分的区间时,只改变当前结点维护的值,暂时不改变该结点左右子树维护的值。通过lazy标记,暂时记录要改变的值。只在需要的时候,才更新。这就是懒惰的思想。

void pushdown(int k)
{
    if(tree[k].lazy){
        tree[k*2].lazy=tree[k*2+1].lazy=tree[k].lazy; //标记下传到左右结点
        int len = tree[k].r - tree[k].l + 1;
        tree[k*2].w = (len-len/2)*tree[k].lazy; //更新左结点
        tree[k*2+1].w = (len/2)*tree[k].lazy; //更新有结点
        tree[k].lazy = 0; //清零标记
    }
}

当需要得到子结点信息的时候再进行更新,就是要将lazy的标记传递给它的左右子树。注意:当需要递归时,一定要将标记下传,保证访问某个结点时,它的父结点不存在任何标记,这样才能保证我们维护的值不会出错。(这段照树抄的)这就是为什么update访问到某个结点时,也需要pushdown进行标记下传的原因。

还有一个小疑问,后来AC后想到每次pushdown都是访问到结点就将lazy标记下传到左右子结点,万一是个叶子结点,它的左右子结点会不会越界?后来画了画,感觉数组大小乘4真的挺神奇的....怎么都不会越界,是我想多了= =


#include <iostream>
#include <cmath>
#include <cstdio>
#include <vector>
#include <map>
#include <cstring>
#include <queue>
#define  ll long long
using namespace std;

struct node
{
    int l,r,w,lazy;
};

node tree[100010*4];
int a[100010*4];
void build(int k,int l,int r)
{
    tree[k].l = l; tree[k].r = r; tree[k].lazy = 0;//lazy标记清0
    if(l==r){
        tree[k].w = 1;
        return;
    }
    int mid = (l + r)/2;
    build(k*2,l,mid);
    build(k*2+1,mid+1,r);
    tree[k].w = tree[k*2].w + tree[k*2+1].w;
}

void pushdown(int k)
{
    if(tree[k].lazy){
        tree[k*2].lazy=tree[k*2+1].lazy=tree[k].lazy; //标记下传
        int len = tree[k].r - tree[k].l + 1;
        tree[k*2].w = (len-len/2)*tree[k].lazy;
        tree[k*2+1].w = (len/2)*tree[k].lazy;
        tree[k].lazy = 0;
    }
}

void update(int k,int l,int r,int v)// 区间修改,l-r区间修改为v
{
    if(l>tree[k].r||r<tree[k].l) return;
    if(l<=tree[k].l&&tree[k].r<=r){
        tree[k].lazy = v;//加标记
        tree[k].w = (tree[k].r - tree[k].l + 1)*tree[k].lazy;
        return;
    }
    pushdown(k);
    update(k*2,l,r,v);
    update(k*2+1,l,r,v);
    tree[k].w = tree[k*2].w + tree[k*2+1].w;
}

int query(int k,int l,int r)
{
    if(l>tree[k].r||r<tree[k].l) return 0;
    pushdown(k);
    if(l<=tree[k].l&&tree[k].r<=r) return tree[k].w;
    return query(k*2,l,r) + query(k*2+1,l,r);
}

int main()
{
    int T,n,t,l,r,w;
    scanf("%d",&T);
    for(int i=1;i<=T;i++)
    {
        scanf("%d%d",&n,&t);
        build(1,1,n);
        for(int j=0;j<t;j++)
        {
            scanf("%d%d%d",&l,&r,&w);
            update(1,l,r,w);
        }
        printf("Case %d: The total value of the hook is %d.\n",i,query(1,1,n));
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值